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前言前言前言前言 

DigiColor是一个计算机控制的多光谱成像系统，用于非接触式颜色测量及捕捉高质量的

可重复图像。DigiColor能够从具有超小或超大面积、凹凸不平表面的样品中以非接触方式获

得反射率或色差数据。传统的颜色测量方法只允许对平坦、均匀的彩色表面进行接触式测量，

而 DigiColor除了可以获取颜色信息，还可以捕捉物体的外观，包括光泽和纹理细节。此外，

DigiColor 不仅能显示颜色，还能显示表面细节（如纹理、光泽、表面特征）。捕获的图像可

以用于软打样，在保留原样本其他表面特征如纹理、光泽等前提下着色到指定的标准色调，

模拟最终产品。多数测量数据可以与图像一起保存、输出、传输、再现和回朔，标准数据的

输出格式允许将数据传输到兼容的商业质量控制、配方软件和颜色通信系统中。 

整个 DigiColor系统由以下部分组成： 

 一台为捕捉可重复的图像而均匀地照亮物体的照明
照明照明

照明箱

箱箱

箱。箱体内嵌 LED 光源和允许

预览、捕获样本图像的黑白摄像机。样品被放置在箱体内抽屉式的承物台上，可缓

慢地推入或拉出照明箱，承物台安装有柜门以防止不必要的杂光进入箱体中； 

 一台带有彩色显示器的计算机
计算机计算机

计算机，是整个系统的控制中枢； 

 一台颜色传感器
颜色传感器颜色传感器

颜色传感器，

，，

，用于计算机显示器的颜色特征化； 

 一块均匀的 ScoColor标准白板（消耗品），用于箱体照明非均匀性校正； 

 一块含有近 240个颜色的特制 ScoColor标准色卡（消耗品），用于相机的日常标定

和校正； 

 DigiColor软件及软件加密狗。 

 DigiColor软件主要实现的功能有： 

 相
相相

相机校准：

机校准：机校准：

机校准：是将设备相关的相机输出信号与设备无关的颜色信息相关联的过程，

使相机处于颜色测量的最佳状态； 

 颜色测量：
颜色测量：颜色测量：

颜色测量：在特定光源下从多光谱图像中获取颜色值或用传统分光光度计测量颜

色。测量数据以色度值（XYZ和 CIELAB）或光谱反射率（以 10 nm间隔从 400 nm

到 700 nm）的形式报告； 

 色差
色差色差

色差测量

测量测量

测量：

：：

：此功能量化标准样本和批量样本的色差及其他 QC指标（如MI等）。

该系统采用国际公认的色差（CIELAB）和较新的 CIE色差（CIEDE2000）公式，以

及 CMC和 CIE 94等色差公式；同色异谱指数（MI）表示被测颜色的同色异谱程

度； 

 监视器
监视器监视器

监视器校准：

校准：校准：

校准：确保监视器在一段时间内性能稳定及真实再现图像颜色，使得不同

的显示器具有相似的颜色特征，显示的颜色不再与设备相关； 

 色
色色

色牢度评估：

牢度评估：牢度评估：

牢度评估：评估测试纺织品色牢度、起毛起球程度以及洗涤品的洗涤能力等，

包括水洗、摩擦、汗渍、光照等变色牢度或沾色牢度。色牢度数据可与图像一起

保存、传输、提取和打印等；  

 纹理分析和模拟：
纹理分析和模拟：纹理分析和模拟：

纹理分析和模拟：创建纹理图像，进行纹理映射等；  

 色彩替换
色彩替换色彩替换

色彩替换（

（（

（软打样）

））

）功能：

功能：功能：

功能：在保持基底纹理细节的同时，用一种颜色替换另一种

颜色。可实现软打样即保留样本纹理、光泽等特征不变，仅更换部分或整体颜

色，是设计师实现色彩搭配的理想工具； 
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 彩色图像处理：
彩色图像处理：彩色图像处理：

彩色图像处理：可对图像进行颜色搜索、替换、统计、分类及质量管理等功能； 

 颜色
颜色颜色

颜色管理

管理管理

管理：

：：

：可导入、导出、保存、传递、管理测量的颜色和配方，并可对数据库

颜色实现各种运算和质量控制； 

 配方计算（选配）：
配方计算（选配）：配方计算（选配）：

配方计算（选配）：实现电脑配色。 
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1.File 菜单菜单菜单菜单 

如图 1-1所示，在此菜单中可执行图像的打开、退出、打印、选择 LED光源端口、抓拍白板、

抓拍色卡、抓拍被测物照片等功能。 

        
图 1-1 File 菜单 

 

1.1	DigiColor支持的图像格式支持的图像格式支持的图像格式支持的图像格式	

DigiColor可以打开和保存大多数常见的图像文件类型，而图像的大小和质量取决于所选

的文件类型。DigiColor推荐使用的文件类型是 RGB-TIF格式文件，便于保存多光谱图像并将

应用程序的其它数据添加到图像文件中。 

DigiColor支持的文件类型： 

 TIF类型文件
类型文件类型文件

类型文件 

DigiColor以两种方式存储 TIF图像文件：（1）TIF多帧格式存储多光谱 RGB单色图像；

（2）以 RGB 格式保存的 CIELAB 彩色图像。应注意在其他图像软件或成像设备中创建的

CIELAB-TIF文件使用的标准光源是 D50还是 D65。在 DigiColor中创建的 TIF文件包含了附加

的数据，这些数据能够被 DigiColor 读取，但可能不会被其他的图像软件识别。应注意在

DigiColor 中重新打开一个被其它图像软件打开并修改过的 TIF 文件时，TIF 中原有的附加数

据可能已被删除或已损坏。 

 BMP类型文件
类型文件类型文件

类型文件 

DigiColor可以打开任何位图图像，但为了可以进行任意颜色的测量，需要对相关的摄像

机进行校准。 

 GIF类型文件
类型文件类型文件

类型文件 

GIF图像常被用在互联网上，通常其体积小，分辨率低。DigiColor可以打开此类文件类

型，但它们在色彩测量或通信方面的用途有限。 

 JPEG(JPG)类型文件
类型文件类型文件

类型文件 

JPEG(JPG)图像的质量受原始图像压缩量的影响，高压缩图像的图像质量会降低，并且会

丢失颜色数据，所以要慎重考虑对高压缩图像进行颜色测量。JPEG(JPG)图像的优点是其占空
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间相对较小，可以便捷的发送给他人浏览。 

 UCIE类型文件
类型文件类型文件

类型文件 

UCIE 是一种特殊格式的文件，包含图像中每个像素的颜色数据。UCIE 类型文件主要用

于特定的图像分析程序，不建议在一般的颜色分析中使用，一是因为其文件大小非常大，可

至 40Mb；二是因为很少有用于商业领域的图像设备支持这种文件类型。 

另外本软件支持的图像格式还有：J2K格式、
格式、格式、

格式、PNG格式、
格式、格式、

格式、HDR格式
格式格式

格式。 

1.2	Open	文件打开文件打开文件打开文件打开	

 DigiColor中打开的图像会自动进行缩放，并将图像整体显示在页面中，用户可以直接看

到整个图像。您可以通过按压 Ctrl键或者 Shift键同时配合鼠标从 File→
→→

→Open打开多个图像。

此外，您可通过 Load Spectral Images加载多光谱图像。 

1.3	Save和和和和 Save	As文件保存文件保存文件保存文件保存	

TIF文件可以存储 LAB或 RGB数据，应用程序的其他特定数据也保存在 TIF文件中。例

如，DigiColor中保存的图像包含从该图像中分析得到的色牢度分级数据，数据的大小和类型

取决于对图像执行的操作，但所有图像会包含 Exif 头信息和当前仪器的校准信息。RGB-TIF

文件在加载时将自动使用其自身的仪器校准数据，使得可以直接在 RGB-TIF文件上进行颜色

测量，而无需另外使用色卡来校准仪器。不建议把 RGB-TIF 格式图像压缩成 JPEG 格式图像

进行颜色测量，因为颜色数据可能会在压缩中丢失。打开一个 LAB-TIF文件，将自动将图像

转换为监视器 RGB，并且不能对图像进行任何的色度测量。LAB TIF 图像中使用的白点是当

前校准光源的白点，通常是 D65。如果在使用 D50作为默认白点的图像应用程序中打开这些

图像，可能会导致某些颜色显示不准确。 

 

图 1-2 Save AS 对话框 

DigiColor约定以 RGB-TIF格式保存多帧多光谱图像，便于 DigiColor在这些文件中存储和

提取颜色信息和其他数据。在使用 Save As保存图像时（如图 1-2），可选择另存为 CIE LAB-

TIF彩色图像和图像压缩方式。 
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1.4	LED	Port	Setting	选择选择选择选择 LED光源光源光源光源端口端口端口端口	

在设备能够正常运行前，需将设备（LED 光源 USB 端口和相机 USB 端口）与计算机连

接。首先接通设备电源并通过 USB线缆将设备与计算机连接（两条 USB线），其中 LED端口

为 USB2.0，而相机端口为 USB3.0，必须连接到计算机相应的 USB3.0端口。 

选择 File→LED Port Setting可选择 LED光源 USB控制端口，出现图 1-3窗口： 

 

图 1-3 LED 设备端口选择界面 

选择下拉栏的端口名称，可勾选方块，设置为默认端口选项。该选项只是告知系统 LED

光源的连接端口，必须与实际的端口一致。 

 

1.5	Preview预览图像预览图像预览图像预览图像	

使用 DigiColor 软件，您可以捕获比较精确的二维或三维样本图像，并将图像数字化保

存在文件中。仪器中的数码摄像头可以预览 (Preview) 或者捕获 (Capture Image)图像及对

选定的彩色区域进行定位。 

在拍摄图像之前，建议您用仪器中的数码摄像头预览 (Preview) 功能，查看样本摆放的

位置和定位，以确保抓拍的图像覆盖期望的区域。 

如果从拍摄的图像中进行颜色测量，则图像样本应放置在机柜中心的 320x200 mm目标

区域内。 

绝大多数的图像是在灰色的底板背景下捕获的。然而对于比较性测量（实验），您应当

确保每次测量的背景一致，以确保测量结果的可重复性。 

 

1.6	Capture	White捕获白板图像捕获白板图像捕获白板图像捕获白板图像	

DigiColor可以选择对每幅图像实施照明非均匀性校正，以牺牲测量速度为代价提高颜色

测量的精度。 

如果需要对图像进行照明非均匀性校正，需要完成以下两步： 

1） 在菜单 Setup → Options → Camera中勾选“Automatic Uniformity Correction”，（见

9.2）； 

2） 将标准白板置入灯箱，利用菜单 File → Capture White，抓怕白板图像。此后，在

抓拍完其他图像后，系统均会自动进行照明非均匀性校正，并保存校正后的图像。 

 

注意：在

注意：在注意：在

注意：在对图像进

对图像进对图像进

对图像进行照明非均匀性校正时，需要注意白板图像的拍摄时间，不能沿用不

行照明非均匀性校正时，需要注意白板图像的拍摄时间，不能沿用不行照明非均匀性校正时，需要注意白板图像的拍摄时间，不能沿用不

行照明非均匀性校正时，需要注意白板图像的拍摄时间，不能沿用不

同时期的白板图像，必须采用当日当时的白板图像。

同时期的白板图像，必须采用当日当时的白板图像。同时期的白板图像，必须采用当日当时的白板图像。

同时期的白板图像，必须采用当日当时的白板图像。 
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1.7	Capture	Chart捕获色卡图像捕获色卡图像捕获色卡图像捕获色卡图像	

DigiColor 以 ScoColor 标准色卡传递颜色信息和校正仪器的颜色特性，在每次使用仪器

之前或仪器使用一段时间间隔后，要进行仪器的校准。为保证颜色测量精度，可对每幅图像

实施照明非均匀性校正（见 1.6）。 

将标准 ScoColor 色卡置入灯箱，利用菜单 File → Preview 预览图像并确保样本位置，

再利用菜单 File → Capture Chart，抓怕色卡图像。仪器校准参见相关章节（见 5.3）。 

 

注意：仪器的校准数据有一定的时效性。在校正仪器时，需要注意色卡图像的拍摄时间，

注意：仪器的校准数据有一定的时效性。在校正仪器时，需要注意色卡图像的拍摄时间，注意：仪器的校准数据有一定的时效性。在校正仪器时，需要注意色卡图像的拍摄时间，

注意：仪器的校准数据有一定的时效性。在校正仪器时，需要注意色卡图像的拍摄时间，

不能沿用不同时期的色卡图像，必须采用当日当时

不能沿用不同时期的色卡图像，必须采用当日当时不能沿用不同时期的色卡图像，必须采用当日当时

不能沿用不同时期的色卡图像，必须采用当日当时的色卡图像校正仪器。

的色卡图像校正仪器。的色卡图像校正仪器。

的色卡图像校正仪器。 

1.8	Capture	Image	捕获捕获捕获捕获被测物被测物被测物被测物图像图像图像图像	

 工具栏图标：     快捷键：Alt+R 

将被测物置入灯箱承物台，必要时可采用相机预览（Preview）功能进行预览定位，利用

菜单 File → Capture Image，抓怕被测物图像。 

为保证颜色测量精度，可对每幅图像实施照明非均匀性校正（见 1.6）。 

 

注意：

注意：注意：

注意： 

 在抓拍被测物图像之前，确保仪器的校准数据的时效性
在抓拍被测物图像之前，确保仪器的校准数据的时效性在抓拍被测物图像之前，确保仪器的校准数据的时效性

在抓拍被测物图像之前，确保仪器的校准数据的时效性；

；；

； 

 如果选择
如果选择如果选择

如果选择“Automatic Uniformity Correction”，则抓拍的图像已经过光照非均匀性校
则抓拍的图像已经过光照非均匀性校则抓拍的图像已经过光照非均匀性校

则抓拍的图像已经过光照非均匀性校

正

正正

正，不可

，不可，不可

，不可再次对

再次对再次对

再次对该图像施行光照非均匀性校正

该图像施行光照非均匀性校正该图像施行光照非均匀性校正

该图像施行光照非均匀性校正；

；；

； 

 仪器的校准数据
仪器的校准数据仪器的校准数据

仪器的校准数据已

已已

已保存在图像中

保存在图像中保存在图像中

保存在图像中，

，，

，可传递到另外一台

可传递到另外一台可传递到另外一台

可传递到另外一台 DigiColor 系统中
系统中系统中

系统中回溯颜色数

回溯颜色数回溯颜色数

回溯颜色数

据

据据

据；

；；

； 

 尽量
尽量尽量

尽量不要使用其他图像编辑软件对图像进行编辑处理，以免丢失仪器校准数据，影

不要使用其他图像编辑软件对图像进行编辑处理，以免丢失仪器校准数据，影不要使用其他图像编辑软件对图像进行编辑处理，以免丢失仪器校准数据，影

不要使用其他图像编辑软件对图像进行编辑处理，以免丢失仪器校准数据，影

响回溯图像中的颜色数据

响回溯图像中的颜色数据响回溯图像中的颜色数据

响回溯图像中的颜色数据。

。。

。 

 

1.8.1 捕获图像步骤捕获图像步骤捕获图像步骤捕获图像步骤 

1) 确保仪器通过 USB 端口（两个）连接到计算机，连接仪器电源，打开开机按钮，通过

LED Port Setting设置 LED光源与计算机连接的端口，相机端口由系统自行侦测； 

2) 在捕获图像前请检查校准日志，确保在 4小时内已校准过仪器。如果已超过校准时效范

围，请参照 5.3章节进行仪器校准（仪器校准前建议进行均匀性校正）； 

3) 将要拍摄的样品放入灯箱中，确保其平稳，关上抽屉； 

4) 选择 File→Preview 预览选项观察图像是否显示完整。如果图像不完整，请重新定位样

本并重新进行预览； 

5) 由菜单 Setup→Options→Camera→”Images save to”选择将图像另存为至 DigiColor 相关

文件夹中。 

6) 获得完整图像后，选择 File→Capture White/ Capture Chart/ Capture Image或者工具栏中
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的 （快门释放）按钮对图像进行捕获，以 RGB Tiff格式保存图像。图像文件名包含

前缀（DC_White, DC_Chart或 DC_Image等）、日期、时间等信息，如： 

a) 文件名 DC_White_03_21_2020_14_44_22.TIF为一副白板图像，拍摄于 2020年 03月

21日 14:44:22； 

b) 文件名 DC_Chart_06_28_2020_08_08_09.TIF为一副色卡图像，拍摄于 2020年 06月

28日 08:08:09； 

c) 文件名 DC_Image_07_01_2020_14_08_39.TIF 为被测物图像，拍摄于 2020 年 07 月

01日 14:08:39。 

 注：Capture White捕获的白板图像用于光源照明非均匀性校准，Capture Chart捕获的

色卡图像用于仪器校准，Capture Image 用于捕获需测量的图像。通过不同的捕获方式，软

件对图像的命名方式不一样，存储到图像中的附加数据也不同，方便用户对图像进行分类管

理。 

2. Edit 编辑编辑编辑编辑 

Edit菜单包含四个选项，可对已选择区域进行 Copy（复制）、Cut（剪切）、Paste（粘贴）

操作。Undo为撤销操作。 

 

3. View 视图视图视图视图 

  

图 3-1 View 菜单 

 点击 View→Toolbar选择工具栏显示模式（标准模式或者精简模式）； 
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 勾选 View→Status Bar，显示窗口状态栏信息，可直接显示出当前光标的坐标值、

RGB值、选择区域等信息； 

 点击 View→Image Pixel打开“图像像素”操作窗口，可对颜色进行查找替换、色域

检查、聚类分析（详见第 7章 Color Imaging）等； 

 点击 View→Advance Clustering打开“高级聚类分析”操作窗口，可对图像颜色进行

聚类分析（详见第 7章 Color Imaging）； 

 点击 View→Imaging Measuring打开“图像测量”窗口，可对图像中的颜色进行测量

（详见第 7 章 Color Imaging）。在进行“图像测量”前，需要保证仪器处于校准状

态，详细情况请参考第 5章 Calibration； 

 点击 View→Measurement Workflow打开“颜色测量工作流”窗口，可对颜色进行测

量（详见第 7章 Color Imaging）；（该功能暂不可用） 

 点击 View→Imaging QC打开“图像质量控制”操作窗口，可对图像中的两个颜色进

行色差分析（详见第 7章 Color Imaging）； 

 点击 View→Texture Mapping打开“纹理映射”操作窗口，可提取图像的纹理信息，

进行纹理映射（详见第 7章 Color Imaging）； 

 点击 View→Color Sorting打开“颜色分类”操作窗口，根据所选的种子颜色对图像

中的颜色进行筛分（详见第 7章 Color Imaging）； 

 点击 View→Manual Grading打开“手动色牢度评级”窗口； 

 点击 View→Light Fastness打开“光照色牢度”分析窗口； 

 点击 View→Multi-Sample打开“多织物色牢度评级”窗口； 

 点击 View→Stain Analysis打开“沾色牢度分析”窗口； 

 点击 View→Histogram 打开“直方图”窗口，里面可查看选取图像界面的 RGB 值； 

 点击 View→Customise 打开“自定义”窗口，里面可设置当前“View”工具栏内快

捷图标按键。 
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4. Selection 测量区域测量区域测量区域测量区域选择选择选择选择 

4.1	Selection	tools	选择工具选择工具选择工具选择工具	 	

DigiColor为用户提供了诸多不同的工具从图像中选择所需的测量区域，您可以根据待选

区域的形状和大小来选择相应工具（如图 4-1）。返回的颜色值是所选区域的像素颜色的平均

值。 

 

图 4-1 Selection tools 菜单 

 

Rectangle:  

矩形工具将选中矩形区域内的所有像素。点击 Rectangle选项，在感兴趣区域的起始

位置按下鼠标左键不松手并在图像上拖动，可以对矩形区域进行选择。 

矩形的左上角是选择区域的起点，由鼠标左键的初始单击位置确定。 

注意：

注意：注意：

注意： 

在

在在

在选中的

选中的选中的

选中的矩形

矩形矩形

矩形图像

图像图像

图像区域

区域区域

区域上单击鼠标右键并从弹

上单击鼠标右键并从弹上单击鼠标右键并从弹

上单击鼠标右键并从弹出

出出

出的

的的

的菜单中选择“

菜单中选择“菜单中选择“

菜单中选择“Save as fixed-rectangle”，
”，”，

”，

可以将选定

可以将选定可以将选定

可以将选定的矩形

的矩形的矩形

的矩形区域

区域区域

区域另

另另

另存为

存为存为

存为固定

固定固定

固定矩形

矩形矩形

矩形（参见

（参见（参见

（参见 Fixed Rectangle Tool）
））

）。

。。

。 

Circle:  

圆形工具将选中圆形区域内的所有像素。点击 Circle选项，按下鼠标左键并在图像上拖

动，就可以进行选择。在鼠标左键拖动过程中，鼠标键按下和松开时对应的位置决定圆的直

径大小。 

注意：

注意：注意：

注意： 

在图像上

在图像上在图像上

在图像上选定的圆形区域

选定的圆形区域选定的圆形区域

选定的圆形区域单击鼠标右键并从弹出的菜单中选择“

单击鼠标右键并从弹出的菜单中选择“单击鼠标右键并从弹出的菜单中选择“

单击鼠标右键并从弹出的菜单中选择“Save as fixed-circle”，
”，”，

”，

可以将选定区域保存为固定圆

可以将选定区域保存为固定圆可以将选定区域保存为固定圆

可以将选定区域保存为固定圆（参见

（参见（参见

（参见 Fixed Circle Tool）
））

）。

。。

。 

Free-Form:  

自由形式工具将选中图像上任意形状区域内的所有像素。按住左键拖动鼠标将增加选定

区域。在定义不规则形状的选择区域时，应使用自由形式工具。如果松开鼠标时选择的区域

没有形成闭合边界，软件将通过连接起点和终点自动闭合不规则形状。 

Magic Wand:  
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魔棒工具选定与目标像素相邻且在公差范围内的所有像素。此工具用于根据目标像素的

颜色选中图像区域。如果任何相邻像素的色差在公差范围内，则选择这些像素并对下一组相

邻像素重复该程序。当没有相邻像素在指定的公差范围内时，选择将中止。此工具用于根据

目标（或种子）像素的颜色选择图像中的相近颜色。 

将公差设置为较低的值将减少选中的像素数。增加“公差”值将增加选定区域中的像素

数。此工具中选择出的区域是连续的，如果在两个或多个单独的图像区域中存在相同的颜色，

只会选择出鼠标单击所选区域的连续部分。 

魔棒“公差”由魔棒公差滑动条（如图 4-2）选定，该滑动条在选定魔棒工具时会自动

弹出，并在选定其他工具时自动隐藏。 

 

图 4-2 魔棒工具“公差”选定滑动条 

 

Fixed Rectangle Tool：
：：

：  

固定矩形工具将选择由固定宽度和高度的矩形来定义区域中包含的所有像素。固定矩形

可以通过使用矩形工具在图像中拖出所需大小的矩形来定义，并通过右键单击图像所选区域

将所选内容保存为固定矩形，如矩形工具部分所述。 

当选择固定矩形工具时，将自动弹出如图 4-3所示窗口。该窗口包含固定矩形选区的长

宽和左上角信息，以及矩形位置是否固定等选项。如果矩形的位置可变，则勾选“Free Left 

Corner”，此时保留矩形大小不变，但矩形左上角的位置由鼠标左键点击决定。如果没有勾

选“Free Left Corner”，则矩形的大小和位置均固定不变。 

固定矩形信息可以保存（Save As）在指定的名字（由图 4-3下拉框决定）下，并根据需

要在下拉框中选取或从下拉框中删除（Delete） 

 
图 4-3 固定矩形窗口 

Fixed Circle Tool：
：：

：  

固定圆形可以使用圆形工具在图像中拖出所需大小的圆，并通过在图像上单击鼠标右键

（如圆形工具部分所述）将所选内容保存为固定圆。 

当选择固定圆形工具时，将自动弹出如图 4-4所示窗口。该窗口包含固定圆形选区的半

径和圆心坐标等信息，以及圆形位置是否固定等选项。如果圆形的位置可变，则勾选“Free 

Centre”，此时保留圆形大小不变，但圆心的位置由鼠标左键点击决定。如果没有勾选“Free 

Centre”，则圆的半径和位置均固定不变。 

固定圆形信息可以保存（Save As）在指定的名字（由图 4-4下拉框决定）下，并根据需

要在下拉框中选取或从下拉框中删除（Delete） 
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图 4-4 固定圆形窗口 

 

Move Tool：
：：

：  

此工具可以将此前定义的选择区域移动到图像中的新位置，并计算新位置的颜色数据。

移动工具适用于除魔棒之外的任何选择工具。 

在此前选定的区域内按住鼠标左键不松手并移动鼠标，可将选择区域拖动到新的位置。

松开鼠标按钮将结束移动，并返回新区域的颜色数据。 

4.2	Selection	filters	选择过滤器选择过滤器选择过滤器选择过滤器	

DigiColor允许自定义需要的过滤器类型，根据所选过滤器对图像进行像素筛选。 

通过 Selection→Filters打开“自定义过滤器”设置界面（如图 4-5所示）。 

Current Filter（
（（

（当

当当

当前的过滤器）

前的过滤器）前的过滤器）

前的过滤器） 

文本框内显示的为当前的选择过滤器，您可以对当前的过滤器进行修改保存、加载和删

除等操作。 

 

图 4-5 定制过滤器界面 

 

Filter indicator（过滤器标识）
（过滤器标识）（过滤器标识）

（过滤器标识） 

 通过勾选“Show Filter Mask（显示过滤器掩膜）”，再选择下拉框中颜色，将对符合过滤

器所设定的色差标准的像素进行屏蔽，使其不参与图像处理。 

De-noise（降噪）
（降噪）（降噪）

（降噪） 

 DigiColor提供了Median（中值）滤波、Blur（均值）滤波、Gaussian（高斯）滤波降噪

方法，您可以根据列表选择所需的降噪方法。详细介绍请参考 8.1.6章节有关图像降噪处理

部分内容。 

Background（背景处理）
（背景处理）（背景处理）

（背景处理） 

可对图像的亮度、饱和度、色调进行自定义调整，分别移除图像中像素更深或更浅的部

分。详细介绍请参考 8.1.7章节有关“Background removal”部分内容。 

Filter by 

 点击 Add按钮，
按钮，按钮，

按钮，DigiColor会新增一个“Filter by”标签栏（如图 4-6），可以根据您的需

要对图像的 L*（亮度）、a*（红绿）、b*（黄蓝）、C（彩度）、h（色调角）设置选择优先级和

正负值公差范围。 
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图 4-6 设定选择过滤器选择标准 

Results（结果）
（结果）（结果）

（结果） 

 设置好参数后，点击 Apply，系统将对图像按过滤器过滤符合要求的像素，在“Results”

中显示符合条件的像素百分比。 

 

 定制的过滤器可以与大多数普通的选择工具（如矩形工具）联合使用，具体方法： 

1) 在定制过滤器界面（图 4-5），选择合适的过滤器（如图 4-5中 test）； 

2) 在状态栏上勾选 Filter On； 

3) 与通常方法一样，用普通工具（如矩形选择工具）选择测量区域（如图 4-7 所示），此

时矩形选区中被指定颜色标记的像素为选中测量颜色。 

 

图 4-7矩形选择工具与过滤器联合使用效果 

 

4.3	选择目标颜色选择目标颜色选择目标颜色选择目标颜色	

 利用以上选择工具，可选取图像上的目标颜色，主要有以下三种方法进行选取： 

1) 选择单个像素：
选择单个像素：选择单个像素：

选择单个像素：使用鼠标，指向图像的彩色区域并单击鼠标左键，将捕获鼠标指向的单

个像素的颜色。 
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2) 选择大块区域：
选择大块区域：选择大块区域：

选择大块区域：从工具栏中选择一个选择工具，当鼠标拉选区域时，软件将给出选定区

域的平均颜色。使用鼠标，指向要测量的图像区域的左上角；按下鼠标左键并移动到区

域的右下角；松开鼠标按钮。必要时，可以与定制过滤器一起使用，更可靠地测量颜色。 

3) 从工具栏中选择 Magic Wand（魔棒工具）并单击要测量的颜色，此时图片上在软件所

设定公差范围内的所有相邻像素均被涂黑显示。所选的目标颜色是公差内所有像素的颜

色（在涂黑之前）。 

注：通过 Setup→Option 设置的 Tolerance（公差） 值决定了此功能所突出显示的颜色

的范围。 
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5. Calibration 校准校准校准校准 

校准菜单如图 5-1所示，包括显示器校准和仪器校准 

 

图 5-1 校准菜单 

5.1	Monitor	Calibration	显示显示显示显示器校准器校准器校准器校准	

为在屏幕上显示精确的色彩图像，需进行显示器校准。显示器校准是维持显示器输出颜

色的稳定性，然后执行特征化处理，以便在屏幕上显示色度准确的图像。屏幕色彩的质量和

精度将受到观察环境的严重影响，为获得最佳的屏幕再现效果，必须尽可能控制周围环境： 

 使用暗室，显示屏上无外部光线照射； 

 确保背景为中性灰色； 

 尽量垂直地观察屏幕。 

较差的环境条件会直接影响感知到的色彩再现的质量而与显示器质量或校准精度无关。 

5.1.1 显示显示显示显示器选项设置器选项设置器选项设置器选项设置 

先将用于显示器校准的颜色传感器插入计算机的串行或者 USB端口。 

显示器的默认背景和图像对比度可通过 Setup→Options→Monitor 标签设置。其中

Contrast（对比度）一般选择为 Normal，如果选择其它选项，可能会影响颜色质量（即选择

其他对比度时，该图像尽量不要再用于颜色测量）。 

显示器校准的相关参数可以在点击菜单 Calibration→Monitor Calibration 后弹出的对话

框（图 5-2）中设置： 

 

 

图 5-2 显示器校准对话框 

 

 Sensor 传感器
传感器传感器

传感器类型

类型类型

类型：

：：

：选择与您的 DigiColor 系统一起提供的传感器类型，我们提供

的是 SCOCIE颜色传感器。 

 Port 端口：
端口：端口：

端口：传感器插入的端口，通常是 COM1 或 COM2 等串行校准器，或者 USB
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类型校准器。可以通过 WINDOWS 系统的菜单“开始”→“设置”→“设备”，查

看颜色传感器连接的端口。 

 Baud rate波特率：
波特率：波特率：

波特率：设置传感器期望的串行通信速度，通常为 9600（仅使用串行校

准器）。 

5.1.2 显示显示显示显示器器器器准备准备准备准备 

打开显示器后，先等待一段时间让其稳定下来，再进行测量。根据环境温度和显示模式，

预热时间在 30-120 分钟之间。我们建议您定期清洁屏幕，以清除指纹和可能干扰颜色准确

测量的多余标记。 

5.2	LCD	Monitors	

LCD 显示器校准应每天进行一次（如显示器移动或关闭，则需更频繁地进行校准），或

在进行任何颜色相关的屏幕评估之前进行校准。显示器打开后需要一段时间来稳定，甚至可

能需要 30-60分钟，具体取决于显示器的型号和环境温度。校准前，确保屏幕上没有指纹或

者其他可能影响颜色测量的标记。 

5.2.1 调节调节调节调节 LCD的的的的亮度及对比度亮度及对比度亮度及对比度亮度及对比度: 

 

图 5-3 显示器亮度、对比度和色温的测量和调整 

 

图 5-4 显示器亮度、对比度和色温的测量和调整 

为最大限度地减少环境光的影响，关闭室内所有照明光源，并拉上房间内所有的窗帘，

以在整个校准过程中保持监视器屏幕不受周围环境光影响。 

 设置显示器色温：
设置显示器色温：设置显示器色温：

设置显示器色温：现代显示器均可设置显示器色温，建议尽量将显示器设置成 D65

或色温接近 6500K。 

 设置显示器对比度：
设置显示器对比度：设置显示器对比度：

设置显示器对比度：液晶显示器上的对比度设置通常小于 100，应调整对比度级别，
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使灰度图上的白色灰阶彼此区别开来（如图 5-4）。若灰阶末端的白色台阶无法单独

区分，则对比度过高，应降低对比度。 

 设置显示器亮度：以便左下角条带上最左边的黑色灰阶在背景中可见。若最后相邻

的灰级无法区分，则增加亮度，直到可以清楚地看到每个灰阶。 

设置对比度和亮度后，不要进一步调整它们，因为这将对显示器的特性产生不利影响。

仔细观察显示器上显示的灰度目标的外观。显示器设置调整成功后，应具有以下特点： 

 显示的灰阶颜色应为中性色（灰色），色块之间没有明显的色调变化； 

 所有相邻的色块之间应该有可察觉的差异——特别要注意灰阶的亮端和暗端。 

不要使用吸盘将监视器传感器吸附在屏幕上，这可能会损坏屏幕。校准器根据颜色坐标

（x，y，Y）检测显示输出，其中 Y表示以每平方米坎德拉（cd/m2
）为单位的亮度。在校准

过程中，测试颜色图片显示在屏幕中央，由传感器测量，在校准过程中保持静止。 

初始阶段是通过调整显示器的亮度和对比度来获得正确的亮度级别。显示器将连续显示

三种颜色：白色、深灰色和黑色。您应该使用显示器的亮度和对比度按钮分别调整白色和深

灰颜色，直到获得白色大约为 100±10 cd/m2
和深灰色大约为 6±2.0cd/m2

的预定亮度值（Y）。 

5.2.2 Monitor Calibration Procedure（（（（显显显显视器校准步骤视器校准步骤视器校准步骤视器校准步骤）））） 

 

图 5-5 显示器颜色测量 

 

当亮度和对比度调整到可以接受时（如图 5-3），系统询问“Adjust Monitor Brightness and 

Contrast（调整显示器亮度和对比度）？”如果在弹出窗口中选择“是”；系统会要求您按照

测量的结果，分别调整显示器的峰值白色，中等灰色和黑色（以弹出窗口式询问“Adjust 

Black…”）的亮度和色温，单击“确定”；然后校准程序将自动进行颜色特征化（如图 5-5）。

传感器将显示和测量选定数量的中性色和原色以及一些测试色，进行颜色特征化，结果将被

储存并用于将监视器 RGB值与 CIE XYZ三刺激值相关联。 

在校准结束后，校准结果将以 CIEDE2000 ΔE 平均值表示。一般地，当ΔE 小于 1 时，

则可认为是一次成功的校准。对于一些高性能的监视器，甚至可以做到ΔE值小于 0.5。 

5.3	Instrument	Calibration仪器校准仪器校准仪器校准仪器校准	

图标：      快捷键：Alt+U 
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图 5-6 ScoColor标准色卡 

 

当仪器开机、重新设置或者照明条件发生变化时，需要对仪器进行校准，以确保仪器可

以依照 CIE颜色标准正确测量颜色数值。 

在进行校准时，需要使用一个具有许多已知色调块的参照物。该参照物默认为仪器附件

ScoColor标准色卡（图 5-6）。将一张 ScoColor色卡放置在摄像头可视区域的中心（参见 1.7

抓拍色卡图像），校准程序将启动一个智能的自动色卡定位程序，该程序尝试在色卡中找到

240个参考色调块的每一个。虽然我们建议将色卡与相机视场框架边缘对齐，但定位程序足

够智能，可以克服轻微的偏差和透视问题。 

我们建议在实际进行校准之前，先进行光照非均匀性校正。 

5.3.1 仪器校准仪器校准仪器校准仪器校准步骤步骤步骤步骤 

确保仪器已打开并连接到计算机，打开灯箱电源并让其至少预热 15分钟。 

1、 通过 Setup→Options→Camera设置相应参数，确保光源、观察者和测量条件等设置

正确。具体参数请参考第 9章 Options介绍。 

2、 将 ScoColor 校准色卡放置在灯箱中的定位标记之间，并使用 1.7 节描述的 Capture 

Chart程序采集色卡图像。 

3、 用矩形选择工具选中色卡中四角上四个十字标记之间区域的所有方块（见图 5-7）： 

 
图 5-7 选择色卡上的矩形区域 

4、 选中 Calibration→Instrument Calibration，如果软件可以定位到色卡的目标块，将出

现如图 5-8界面，并弹出图 5-9对话框： 
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图 5-8 色卡颜色自动定位 

 

图 5-9 人工确认定位是否正确 

 

5、 请确保所有的白色正方形被定位在颜色方块中。如果白色正方形定位不准确，请

点击“否”，则将出现如图 5-10提示：可重新设置定位参数或调整色卡位置并重新

拍摄色卡图像 

 
图 5-10 定位失败的处理 

6、 如果定位不准确，可调整 Setup→Options→Camera中的 “Tolerance”（公差）和Min

（最小值）以及Max（最大值）值并重新进行定位。 

设置中的“公差”滑块的值作为判定 RGB空间中相邻的两个点是否为不同的色

度的依据，超过这个值的两个空间点，则系统认定它们拥有不同的色度。所以，如

果“公差”被设置的太小，系统将判定 RGB空间中距离较近（色度较接近，但距离

超过设定值）的两点为不同的色度点，导致很难划分出准确的色度范围；如果设置

的“公差”太大，系统将判定 RGB空间中距离较远（色度差异较大，但距离小于设

定值）的两点为相同的色度点，导致判定结果与实际产生较大偏差。 

Setup→Options→Camera中的Min（最小值）和Max（最大值）与软件在色

卡上搜索的方块大小有关。实际的色块区域（以像素为单位）取决于拍摄图像时使

用的分辨率，不能与屏幕上看到的分辨率混淆，因此图像显示时的缩放功能与所考

虑的区域无关。将区域设置得太小会导致程序找到的色块目标比色卡上真实的小正

方形块要小。结果可能会导致程序会找到多个色块目标，而这些色块目标并非真正

的需体现的色卡颜色。将区域设置得太大会阻碍程序搜索到与色卡上小方块大小相

匹配的目标。因此，最大值和最小值设定的目的是为了较好地克服周围的颜色“噪

声”而找出色卡中各个方块。要确定最佳的最小值和最大值，请从工具栏中选中矩

形形状或魔棒选择工具，然后选中色卡上的白色正方形（如：色卡上 A1位置）。软

件底部的状态栏上将显示小方块大小，如：S:(70*70)。然后将最大值设置为比这个

尺寸大 5（即 75），将最小值设置为比这个尺寸小 20（即 50），点击确定，则最大
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值和最小值设置完毕。 

 

7、 定位准确并校准完成后，将出现一个如图 5-11对话框，显示校准结果： 

 

图 5-11 仪器校准结果 

结果会同时显示一个柱状图和一个数据表。条形图与色块的数量有关，横坐标表示的

是色差值，纵坐标表示的是相应色差值下的方形色块数量的百分比。右侧数据表根据色差

的最大值、最小值、平均值和中值给出校准性能。作为指导性的意见，如果平均值和中位

数等于或小于 1.5，且最大值小于 5，则校准可视为良好。色差值是根据 CIEDE2000公式计

算的，这是一个较新的 ISO色差评估标准。 

我们建议每四小时进行一次校准，开关机或照明条件或测量条件发生任何变化后均要

进行校准。如果样本图像存储为 RGB-TIF格式文件，则无需保存校准图像，但对于任何关

键工作，最好将校准图像与样本图像一起保存。任何未存储为 RGB-TIF的样本图像应和其

相应的校准图像一起被存储为位图（BMP）或 JPEG，这将使正确的仪器校准可用于任何后

续的颜色测量和回溯历史测量。 
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6. Color Management 色彩管理色彩管理色彩管理色彩管理 

通过 DigiColor软件的 Color Management菜单可以使用 DigiColor拥有的颜色质量控制

程序包。通过 DigiColor软件可以连接一系列的传统分光光度计，并且将测量出的颜色光谱

数据保存在 DigiColor数据库中。光谱数据可以用作传统的颜色质量控制，也可以用作图像

的再次着色。 

目前软件支持的分光光度计有： 

 Gretag MacBeth Color-Eye 580 

 Gretag MacBeth Color-Eye 2145 

 Gretag MacBeth Color-Eye 2180 

 Color i7 

 MS-2020+ 

 CS-Dummy 100 （模拟演示） 

 Gretag MacBeth Color-Eye 3000 

 Gretag MacBeth Color-Eye 3100 

 Gretag MacBeth Color-Eye 7000 

 Gretag MacBeth Color-Eye 7000A 

 DataColor SF500 

 DataColor SF600 

 X-Rite Ci64UV 

6.1	DigiColor数据库数据库数据库数据库	

 DigiColor 使用 SQL 服务器数据库来保存颜色数据用于颜色的质量控制及颜色的重新着

色。在安装 DigiColor 时，DigiColor 同时安装了所有所需的 SQL 服务器文件。您必须确保没

有管理员权限的软件使用者可以获得访问及运行 SQL 服务器数据库的必要许可。如果您不

确定这种情况，您应该咨询网络管理员。 

6.1.1 Database Structure 数据库结构数据库结构数据库结构数据库结构 

 DigiColor数据库主要分成三个部分：颜色样本，色域检查，光源。每个部分由一个或者

一个以上的数据类型组成，为用户数据提供结构。 

6.1.2 Illuminants 光源光源光源光源 

您可以外加光源于 DigiColor 中。但使用的数据格式务必正确。我们建议您在需要添加

新光源前联系 DigiColor客服。 
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6.1.3 Gamut Checking 色域检查色域检查色域检查色域检查 

 DigiColor可以检测被测样本的颜色是否在色域中。这可向用户表明所选的颜色是否可以

用给定的一系列着色剂配成，并充当筛选工具，在色度开发之前，将超出色域范围的颜色标

记给用户。DigiColor是通过存储一系列着色剂的光谱数据，并计算可能的色域来做到这一点。 

6.2	Spectro	Measuring	光谱测量光谱测量光谱测量光谱测量	

 工具栏图标：    快捷键：Ctrl+T 

6.2.1 连接分光光度连接分光光度连接分光光度连接分光光度计计计计 

 如果您的分光光度计型号出现在本节开头的列表中，那么您可以将它直接连接到

DigiColor软件上，并可直接测量存储为 DigiColor数据库中新的颜色样本。 

用分光光度计测量颜色的步骤： 

a) 插入分光光度计串行数据线至电脑端； 

b) 选择 Color Management→Spectro Measuring，弹出如图 6-1 Current Spectro窗口 

c) 在 Current Spectro对话框中选择您的分光光度计型号，见图 6-1： 

 

图 6-1 连接分光光度计对话框 

d) 选择好后，默认的串行通信口将被加载； 

e) 此分光光度计将是之后所有测量默认的分光光度计。 

6.2.2 校准分光光度校准分光光度校准分光光度校准分光光度计计计计 

分光光度计需要依据产家说明进行校准。在可能的情况下，DigiColor将读取仪器的状态

来决定是否进行校准。如果需要进行校准，“测量”按钮将会变灰直到校准结束（如图 6-2）。 
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图 6-2 分光光度计测量参数界面 

6.3	Data	Manager	数据管理数据管理数据管理数据管理	

图标：   快捷键：Ctrl+M 

6.3.1 System Codes 系统代码系统代码系统代码系统代码 

 System Code是 DigiColor数据库中颜色样本数据的第一分级。所有数据必须包含在特

定的系统代码中。 
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6.3.2 创建一个创建一个创建一个创建一个 System Code 

 

图 6-3创建 System Code界面 

a. 打开 Color Management→Data Manager→System（如图 6-3） 

b. 点击 Add New创建新的 System Code； 

c. 在 System Code文本框中键入名称； 

d. 在 Description文本框键入任意的描述； 

e. 点击 Save按钮保存
保存保存

保存数据。 

6.3.2.1	 删除删除删除删除 System	Code	

 选中需要删除的行，然后点击 Delete即可删除数据。如待删除的 System Code下已经

存放有数据，则需先行删除相应数据。 

6.3.3  Samples 颜色样本颜色样本颜色样本颜色样本 

DigiColor中的 Samples（颜色样本）中包含了单个颜色的光谱数据以及相关的测量条

件等。数据库中颜色样本数据可以从分光光度计测量获得、从适当的 ASCII文件导入、通

过键盘直接输入或用 DigiColor软件测量生成。 

 颜色样本分为两个级别。顶层是 System Code，每个 System Code被分成一个或多个

Sample Groups（样本组）。 

6.3.4 Sample Groups 样本组样本组样本组样本组 

Sample Groups是 System Code的子分区，包含一个或多个颜色样本。例如，特定供应商

的 System Code可以进一步划分为一个样本组的集合，详细说明了该供应商的不同产品类型。 
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6.3.4.1创建一个样本组创建一个样本组创建一个样本组创建一个样本组 

 

图 6-4创建样本组界面 

a. 打开 Color Management→Data Manager→Samples；（如图 6-4） 

b. 从下拉列表中选择要插入新样本组的 System Code； 

c. 点击 Add New添加一组新的样本组； 

d. 在 Sample Group Name文本框中输入新的样本组名称； 

e. 在 Description文本框键入任意的描述； 

f. 点击 Save按钮保存新的样本组至数据库中； 

g. 在创建样本组后，您可以在其中添加颜色样本。 

6.3.4.2删除样本组删除样本组删除样本组删除样本组 

选中需要删除的行，然后点击 Delete即可删除数据。 

6.3.5 加载颜色样本加载颜色样本加载颜色样本加载颜色样本 

6.3.6 从文件中导入数据从文件中导入数据从文件中导入数据从文件中导入数据 

DigiColor目前支持三种文件格式从第三方应用导入数据，分别为 QTX格式、DAT格式和

TXT 格式。DataColor 和 GretagMacbeth 软件包一般通过使用 QTX 格式在不同应用程序之间

交换颜色信息。DAT格式是一种老的通用格式，它只携带反射率数据和有限的测量条件信息。 
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6.3.6.1	QTX文件文件文件文件	

 QTX格式是一种拥有分层结构的文件格式，允许交换额外的管理数据。在 QTX格式下，

目前 DigiColor只支持光谱数据和测量环境数据，不支持其他数据类型。 

6.3.6.2	DAT文件文件文件文件	

 DAT格式是一种平面结构的文件格式，只能导入反射率值和测量环境数据。这种格式支

持老的第三方颜色系统（Eurocolour、 ICS-Texicon 和 MacBeth）。如果需要将反射率数据导

入第三方软件（如 Excel或类似软件），这可能是最好的格式。 

6.3.6.3	TXT文件文件文件文件	

TXT文件格式是 DigiColor支持的一种文件格式，导出每个光源对应的 CIE颜色数据。 

6.3.6.4	 导入文件导入文件导入文件导入文件	

 导入的数据作为颜色样本存储在样本组中。在导入数据之前， System Code 和 Sample 

Group都必须已经存在于数据库中（如图 6-5）。（详情参考“创建 System Code”和“创建样

本组”） 

a. 打开 Color Management→Data Manager→Samples； 

b. 从下拉列表中选择目标 System Code； 

c. 在 Sample Group表中选中目标样本组的名字； 

d. 点击 Import按钮，将出现 Open File对话框（如图 6-6）； 

e. 选择所需导入的文件，如 DAT格式，点击“打开”，将显示“选择样本”对话框（如图

6-7）； 

f. 在“样本”列表中选择一个或多个所需的样本。在按住控制键的同时单击样本名称（CTRL+

鼠标左键单击）将允许添加多个样本； 

g. 单击右箭头按钮（=>）将所需样本传输到选定列表（如图 6-7）。 

h. 点击“OK”按钮开始复制数据（如图 6-87）。进度条将显示当前数据导入状态（如图 6-

9）。当进度条消失时，传输完成。 
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图 6-5导入数据文件界面 

 

图 6-6 “打开”对话框 

 

图 6-7选择样本对话框 
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图 6-8选择样本对话框 

 

图 6-9导入数据进度图 

 

覆盖已存在的样本

覆盖已存在的样本覆盖已存在的样本

覆盖已存在的样本 

 如果在样品导入期间，同一名称的样本已经存在于数据库中，则显示警告对话框，询问

是否覆盖已有数据。 

如果选择“Yes”，新的样本将覆盖老的同名称样本； 

如果选择“No”，则会出现一个对话框，您需要通过对话框重命名样本，使其顺利的导入到

数据库中。 

6.3.6.5	 用户键入用户键入用户键入用户键入光谱数据光谱数据光谱数据光谱数据	

用户可以通过键盘输入颜色样本的光谱反射率数据。要做到这一点，您必须知道您所拥

有的光谱数据的波长范围和波长间隔。光谱数据以每个波长的反射率百分比的形式输入。 

 

图 6-10键入光谱数据界面 

h 
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a. 打开 Color Management→Data Manager→Samples（如图 6-10），选中相应的

System Code； 

b. 在 Sample group表中选择所需的样本组； 

c. 点击 Add New按钮； 

d. 键入样本名称并作描述； 

e. 从下拉列表中选择光谱长度和波长间隔。输入的网格数据将自动配置成所选光谱特

性的正确格式； 

f. 在每个波长后的输入框键入相应的反射率百分比； 

g. 点击 Save按钮保存颜色样本至数据库中。 

h. 光谱表的末尾包含输入的反射值的校验和。这是利用对照标准数据的发布值来检查

输入值。一些零售商提供一个校验和来粗略检查键盘输入的准确性。 

6.3.7 Substrates or Bases 基基基基底底底底色色色色 

用于色域检查的所有着色剂必须与特定的基色相关联。基底色或基色由一个颜色样本组

成，该样本是在不添加任何染料或颜料的情况下对基础颜色的光谱测量。可以加载许多基色，

但它们不能互换。每个基色都自有一组着色剂数据。基色数据必须在着色剂之前被加载。 

6.3.8 输入输入输入输入一组一组一组一组新的新的新的新的基色基色基色基色 

在输入新的基色之前，必须将其作为颜色样本通过测量导入到数据库中。 

 

图 6-11输入新的基色界面 

a. 从 Data Manager中选中 Bases（如图 6-11）； 

b. 从下拉列表中选择基色所属的 System Code； 

c. 点击 Add New按钮。 

d. 键入新的基色的名称； 

a) Benjamin Moore的基色命名：
的基色命名：的基色命名：

的基色命名： 

b) 数据库中基色的名称是一个空格分隔的字符串，包含四个字段，例如“W3191B 126 
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0.00 0.031746”。 

c) 第一个字段（“W3191B”）标识基色；               

d) 第二个字段（“126”）表示填充体积（fl.oz）；               

e) 下列两个字段（“0.00”和“0.031746”）表示最小和最大的合成 R浓度百分数。 

e. 从下拉列表中选择 Colour Sample用于基色的测量； 

f. 点击 Save按钮添加新的基色至数据库中。 

 

图 6-12保存新的基色 

 

可以在 System Code中添加许多基色，但是系统之间不能共享基色。当系统中有用到基

色时，必须将基色添加到系统中。 

6.3.9 Dyestuffs/Colorants 染料染料染料染料/着色剂着色剂着色剂着色剂 

必须将色域检测所需的任何染料或着色剂添加到数据库中。着色剂文件不是某个系统特

定的，所以只需要加载一次。染料和着色剂组合在一起，一个染料组可能包含许多着色剂。

不必为系统加载每种着色剂，只需要加载标记色域所需的染料和着色剂。 

6.3.10 输入染料和着色剂输入染料和着色剂输入染料和着色剂输入染料和着色剂 

a. 从 Data Manager中选中 Colorants； 

b. 在 Dyestuffs/Colorant Groups中点击 Add New按钮； 

c. 输入新的组名； 

d. 点击 Save按钮保存。 

e. 在 Dyestuffs/Colorant中点击 Add New按钮； 

f. 输入名称至 Dyestuff/Colorant Name； 

g. 点击 Save按钮保存。 

若要添加其它染料或着色剂，请重复上述 e至 g步骤。 
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图 6-13添加 “Dyes/Colorant”组至对话框 

 

图 6-14添加单个着色剂至着色剂组 

6.3.11 Colorants Loading 加载着色剂加载着色剂加载着色剂加载着色剂 

为了在色域检测或配方中使用特定的着色剂，必须将每个着色剂的校准数据加载到数据

库中。所需的校准数据必须同颜色样本一样加载到数据库中。颜色样本应以已知的不同浓度

为每种着色剂制备。每种着色剂至少应准备 5个样本。 
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图 6-15 添加着色剂数据至着色剂文件 

a. 选择 System Code中的着色剂； 

b. 选择需加载的特定的基色； 

c. 选择 DigiColor作为工艺代码 

d. 单击 Add Dyestuff/Colorant按钮，选择基色所需的所有着色剂。 

染料（着色剂）选择：

染料（着色剂）选择：染料（着色剂）选择：

染料（着色剂）选择：  

 

图 6-16添加染料对话框 

a. 选择所需的染料组； 

b. 从染料列表框中选择所需的染料； 

c. 单击 Add按钮将选定的着色剂传输到选定的 System Code。 

6.4	Quality	Control	 质量质量质量质量控制控制控制控制	

图标：    快捷键：Ctrl + Q 

您可以使用“颜色质量控制”功能测试数据库中样本组与标准颜色之间的色差对比情况。

根据所设定的参数标准，通过颜色对比，DigiColor 将判定每个对照组的色差结果（如图 6-

17）。您可以根据需求，查看相应标签栏的颜色分析反馈数据或者色差对比结果，也可以通

过测试结果获取 View Samples（查看样本信息），Reflectance/Transmittance（反射率），

Brightness（明度），Whiteness（白度），Yellowness（黄色），Staining（色沾性），Color Change

（色变分级），Strength（色强度），Opacity（不透明度），Color Constancy（色恒常性），CIECAM02

（色貌）等数据。  
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通过 Color Management→Quality Control打开 DigiColor图像质量管理，将出现以下窗口

（如图 6-17）： 

 
图 6-17 Quality Control操作界面 

以下是窗口控件的说明：

以下是窗口控件的说明：以下是窗口控件的说明：

以下是窗口控件的说明： 

Standard：
：：

： 此项为选择数据库中标准颜色样本，用于与测量样本进行对照。 

Samples：
：：

： 此项允许您添加多个样本，选择您所需的样本与标准颜色进行色差比较。 

Add：
：：

：  新增测量样本至样本框中。 

Deselect：
：：

： 取消选择样本。 

Remove：
：：

： 此按钮用于删除所选的样本。 

Print：
：：

：  此按钮用于打印颜色管理数据。 

Save as：
：：

： 将数据另存为。 

Close：
：：

：  此按钮用于关闭“Quality Control”对话框而不进行保存。 

Calculate：
：：

： 开始计算按钮。 

Pass/Fail：
：：

： 此栏目用于显示所选的对照组在不同的光源下的色差。显示亮度（L）、色

度（C）、色调（H）、色差（E）的差异值。当这四个差异值都在 Tolerances

规定的范围内时，结果显示为“P（通过）”。反之，则为“F（失败）”。 

Colorimetric parameters：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。通过在“kL”文本框中输入所需值，

可以调整任何公式的“明度权重”参数。若此参数用于“可接受性”的权

重色差方程，则在这种情况下，应将其设置为值 2。如果需要可感知的色

差，则参数应设置为 1。 

Tolerances:  定义了标准颜色的公差范围（如图 6-18）。可以根据明度差（∆L）、彩度差

（∆C）、色调差（∆H）的正负值范围和ΔE（色差）来设定公差。 

 

图 6-18公差设置 

Environment：
：：

：设定色貌模型 CIECAM02观察环境参数。对于环境参数，根据环境白场亮

度和观察介质白场亮度的比值，将照明环境分为三类，即 Average（一般），

Dim（昏暗），Dark（黑暗）。La为适应场亮度，用来度量人眼对照明环境
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的适应状态，单位为 cd/m2
；Yb为背景相对亮度，指的是背景相对于参考

白的亮度。只有在应用“CIECAM02”时，才用到这些环境参数。 

Save STD：
：：

： 保存标准颜色及公差范围至数据库。 

Save BAT：
：：

： 批量保存颜色样本及公差范围至数据库。 

6.5	Color	Specification	 颜色特征颜色特征颜色特征颜色特征	

图标：    快捷键：Ctrl + P 

您可以使用“颜色特征”功能检测不同样本在不同光源下的颜色数据。根据所设定的参

数标准，通过软件分析，软件将给出样本在不同颜色空间下的刺激值及其它特征。“颜色特

征”功能可提供的颜色空间有“CIELAB”颜色空间，“CIELUV”颜色空间，“HunterLab”颜色

空间，“Munsell”颜色空间以及“CIEXYZ”颜色空间，并且可获得“Reflectance/Transmittance

（反射率/透过率数据）”，“Curves（反射率/透过率曲线）”，“Chromaticity（色度图）”及“Optical 

Density（光密度）”等数据。 

通过 Color Management→Color Specification 打开 DigiColor 颜色特征，将出现以下窗口

（如图 6-19）： 

 

图 6-19 Color Specification操作界面 

 

Add：
：：

：  新增测量样本至样本框中。 

Delete：
：：

：  删除所选样本。 

Colorimetric parameters：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。 

Print：
：：

：  此按钮用于打印色差数据。 

Save as：
：：

： 将数据另存为。 

Close：
：：

：  此按钮用于关闭“Color Specification”对话框而不进行保存。 

Calculate：
：：

： 开始计算按钮。 
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6.6	Shade	Search	颜色查找颜色查找颜色查找颜色查找	

Shade Search功能允许按设置的颜色参数，根据所选取的标准颜色，对数据库中的颜色

进行查找，找出符合公差要求的颜色。 

通过 Color Management→Shade Search打开 DigiColor颜色查找，将出现以下窗口（如图

6-20）： 

 

图 6-20 Shade Search操作界面 

Colorimetric parameters：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。通过在“kL”文本框中输入所需值，

可以调整任何公式的“明度权重”参数。若此参数用于“可接受性”决策

的权重色差方程，则在这种情况下，应将其设置为值 2。如果需要可感知

的色差，则参数应设置为 1。 

Formula：
：：

： 您可以根据下拉列表选择所需的色差公式。 

Observer：
：：

： 默认选项 10度，
，，

，用于色差计算的标准观察者数据。大多数的标准和颜色

测量设定为 10度的观察者数据。一般情况下选择“10”，除非消费者或者

特殊的实验方法一定要设定为“2” 度。 

Selected：
：：

： 该列表框中的光源即为参与运算的光源。如果您想更换或添加其它光源，

可通过左边的“=>”或“<=”按钮进行选择。 

Standard：
：：

： 此项为选择数据库中标准颜色样本，作为颜色查找的标准。 

Searching in：
：：

： 通过此项您可以选择颜色的搜索范围。搜索范围有“Whole database（整

个数据库）”，“Single System Code（单个系统代码）”，“Single Sample Group

（单个样本组）”，您可以选择其一作为搜索范围。 

Sorting by：
：：

： 软件可以根据用户的选择进行排序，可将选择标准设定为∆L（明度差）、

∆C（彩度差）、∆H（色调差）、∆E（色差）、MI（同色异谱指数）其中之一

的变化值大小对结果进行排序。 

Searching for：
：：

：通过此项可以设置搜索的标准，即公差范围。您可设定设定为∆L（明度

差）、∆C（彩度差）、∆H（色调差）、∆E（色差）的变化范围作为搜索标准。 

Max Returned：
：：

：此项为允许搜索结果显示的最大颜色数量。 

Data：
：：

： 结果网格中将显示所检测到的颜色的数据。依次为颜色编号（名称），色

差值等信息。“Data”后的三个标签栏分别为由“CIELAB a*b*”，“CIELAB 

L*C*”，“色度差”组成的二维坐标，“Data”中的颜色将在相应各个二维
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坐标中显示出。 

Print：
：：

：  此按钮用于打印颜色数据。 

Save as：
：：

： 将数据另存为。 

Close：
：：

：  此按钮用于关闭“Shade Search”对话框（如图 6-19）而不进行保存。 

Search：
：：

：  开始进行搜索。 

6.7	Palette	调色板调色板调色板调色板	

DigiColor为您提供了 Palette（调色板）功能，调色板是用于管理和调用颜色的工具。

通过 Color Management→Palette可以选择调色板的“新建”，“打开”，“重命名”，“导

入”，“导出”操作，并且软件也提供了“Macbeth Test Chart（X-Rite颜色测试色卡）”作为

简易调色板。 

6.7.1 新建调色板新建调色板新建调色板新建调色板 

通过 Color Management→Palette→New新建调色板，将出现以下调色板布局窗口（如图

6-21）： 

 

图 6-21 设计调色板布局 

Layout：
：：

：    为本次的调色板布局命名。 

No. of tiles across：
：：

： 调色板方块横向排列个数。 

No. of tiles down：
：：

： 调色板方块纵向排列个数。 

Height of tile：
：：

：  每个调色板块的高度（以厘米为单位）。 

Width of tile：
：：

：  每个调色板块的宽度（以厘米为单位）。 

Spacing：
：：

：Across：
：：

：  相邻间的横向调色块之间的距离（以厘米为单位）。 

Spacing：
：：

：Down：
：：

：  相邻间的纵向调色块之间的距离（以厘米为单位）。 

若为默认调色板参数，点击 OK，出现以下界面（如图 6-22）： 
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图 6-22调色板界面 

鼠标左键点击某个调色板块再点击菜单栏的 Tile或者在调色板块上右键，有三种方法可

对所选的调色板块进行“调色”： 

1. Import：
：：

：通过 Import 向调色板块导入所需的颜色数据，支持的数据格式有 QTX 格

式、DAT格式及 TXT格式。 

2. Numeric Input：
：：

：可通过颜色测量/手动输入颜色值/在数据库中选择颜色样本对调色

板块进行颜色数据导入。 

3. Color Picker：
：：

：通过选择的颜色空间系统对调色板块进行颜色的导入。DigiColor提供

的颜色空间有“CIELab颜色空间”，“Munsell颜色系统”。此时输入的颜色不具备光

谱数据。 

Shade Search：
：：

：当通过上述任意方法对调色板块进行颜色导入后，点击 Shade Search，

系统则将所选颜色作为标准颜色，在公差范围内进行颜色查找。通过此窗口下的 Option→

Shade Search打开公差设置窗口，其中的各个参数介绍请参考 6.6章节相关内容。 

Fine Tuning：
：：

：当通过上述任意方法对调色板块进行颜色导入后，点击 Fine Tuning，系统

则将所选颜色作为标准颜色，对颜色进行微调。 

Tile Properties：
：：

：此项对选定的调色板块进行命名及备注。 

6.7.2 Macbeth Test Chart测测测测试试试试色卡色卡色卡色卡 

 Macbeth Test Chart是一个包含 24个彩色方块的图表，按 6×4排列。它的尺寸约为 280

毫米*216 毫米（11 英寸*8.25 英寸）。这张色卡取名为“Macbeth”源自它的开发商和制造

商。 
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图 6-23 Macbeth Test Chart测试色卡 

图表的色块具有光谱反射率数据，旨在模拟自然物体的反射，如人类皮肤、树叶和花朵，

在各种光照条件下，特别是在典型的彩色照相胶片上，具有一致的颜色外观，并随着时间的

推移保持足够的稳定。为了作为相机校准标准，每一个 Macbeth色卡都是按照非常严格的色

度公差制造的，色块颜色值需要在使用期间保持其精确的光谱特性。  

 在数码摄影时代，Macbeth 色卡非常流行并广为使用，尤其是在数码相机仿真应用和许

多打印质量控制测试中。由于图表的视觉外观在摄影界非常有名，将 24个指定的颜色值重

新用作标准的色块靶中色块的核心组，用于测试现代油墨和介质的耐光性。这些颜色值在多

通道喷墨打印机中很好地实现了关键的颜色混合转换技术，同时节省了正确评估墨水组的整

体光褪色特性所需的色块数量。 

6.8	Utilities	实用工具实用工具实用工具实用工具	

 此菜单栏提供了以下四种实用工具：可以将打开的调色板里的颜色拖拽到相应的实用工

具软件里，完成相应的功能 

 Color Viewer：
：：

：  颜色查看器，查看颜色数据。 

 Color Tolerance：
：：

：  根据 CIELAB LC/Ch/Lh组成的二维坐标查看颜色色差。 

 Color Difference：
：：

：  直观的查看两个颜色的色差不同。 

Metamerism & Color Constancy：
：：

：直观查看两种颜色视觉上的同色异谱及色恒常性。 

6.8.1	Color	Viewer	颜色查看器颜色查看器颜色查看器颜色查看器	

 通过 Color Management→
→→

→Utilities→
→→

→Color Viewer打开颜色查看器界面（如图 6-24所示）。

在一个打开的调色板里选中一个待查看的颜色，按下鼠标左键不松手，拖动到颜色查看器窗

口，松开左键即可将一个颜色拖拽到颜色查看器（如图 6-25）。采用同样的方法，可以拖拽

更多的颜色到颜色查看器。 
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图 6-24颜色查看器 

 

 

图 6-25 从打开的调色板拖拽一个颜色到颜色查看器 

 改变查看器背景颜色：

改变查看器背景颜色：改变查看器背景颜色：

改变查看器背景颜色：在颜色查看器的背景区域点击鼠标右键，将弹出更改背景颜色菜

单如图 6-26所示。从菜单中选择合适的背景颜色，可以模拟查看不同背景下颜色的外貌。 
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图 6-26 改变颜色查看器背景颜色 

 改变

改变改变

改变显示的

显示的显示的

显示的颜色

颜色颜色

颜色块大小

块大小块大小

块大小：

：：

：在颜色查看器的某个色块里点击鼠标左键选中色块，此时色块

四周出现黑色的边框线（如图 6-24,6-25所示），用鼠标左键点击四边中间或四角上的黑方块

不松手，拖曳鼠标可调整色块的大小。 

 

图 6-27 颜色查看器色块操作 

 

色

色色

色块操作

块操作块操作

块操作：

：：

：在颜色查看器的色块里点击鼠标右键，弹出如图 6-27 的菜单，选中相应菜

单可对色块进行操作，包括复制（Copy），粘贴（Paste），删除（Remove），前置（Bring to 

Front），后置（Sent to Back），前移（Bring Forward），后移（Sent Backward），颜色微调（Color 

Adjust）。 

 

6.8.2	Color	Tolerance颜色颜色颜色颜色容差容差容差容差	

 通过 Color Management→
→→

→Utilities→
→→

→Color Tolerance打开颜色容差界面（如图 6-27所示）。

在一个打开的调色板里选中一个感兴趣的颜色，按下鼠标左键不松手，拖动到颜色容差窗口，
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再松开左键即可将一个颜色拖拽到颜色容差窗口。 

 在颜色容差界面（如图 6-28 所示）有三个九宫图案，分别代表 CIELAB LC, hC 和 Lh 平

面，每个九宫图的中心为标准颜色，中心色块四周 8个色块与中心色块的色差相等，调整底

部的水平滑条可改变色差的大小。通过颜色容差小程序可以模拟颜色朝不同方向等色差改变

后的效果。例如：图 6-28所示为九宫图中心颜色朝不同方向变化到 CIEDE2000 色差为 4时

的各种颜色。 

 

图 6-28 颜色容差界面 

6.8.3	Color	Difference色色色色差差差差	

 通过 Color Management→
→→

→Utilities→
→→

→Color Difference打开色差界面（如图 6-29所示）。

在一个打开的调色板里选中一个感兴趣的颜色，按下鼠标左键不松手，拖动到色差窗口，再

松开左键即可将一个颜色拖拽到色差窗口。采用同样的方法，可以拖拽另一个颜色到色差界

面。 

 改变

改变改变

改变色差界面

色差界面色差界面

色差界面背景颜色：

背景颜色：背景颜色：

背景颜色：色差界面的左上角文字表示当前所用光源（背景颜色），中间

两个色块之上的白色小色块显示不同光源下的白色色貌。改变背景颜色可模拟显示两个色块

在不同光源之下的色差变化情况。在左上角文字上点击鼠标右键，将弹出更改背景颜色菜单

如图 6-30所示。从菜单中选择合适的背景颜色，可以模拟查看不同背景下色差的变化情况。 

 改变

改变改变

改变色差

色差色差

色差参数

参数参数

参数：

：：

：在色差界面背景空白处点击鼠标右键，将弹出更改色差参数菜单如图 6-

31所示，可以改变色差公式和明度权重因子等。 
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图 6-29 色差界面 

 

图 6-30 改变色差界面背景颜色 

 

图 6-31 改变色差参数 
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6.8.4	Metamerism	&	Color	Constancy同同同同色异谱及色恒常色异谱及色恒常色异谱及色恒常色异谱及色恒常	

 通过 Color Management→
→→

→Utilities→
→→

→Metamerism & Color Constancy 打开同色异谱及色

恒常界面（如图 6-32所示）。在一个打开的调色板里选中一个感兴趣的颜色，按下鼠标左键

不松手，拖动到同色异谱及色恒常窗口，再松开左键即可将一个颜色拖拽到同色异谱及色恒

常窗口。采用同样的方法，可以拖拽另一个颜色到同色异谱及色恒常界面。 

 在同色异谱及色恒常界面可同时显示两个颜色在不同光源下的色差、同色异谱及色恒常

性。通过鼠标右键点击空白处，可弹出改变光源个数的菜单如图 6-33 所示。可选光源个数

有 1个，2个或 4个等。在每个角落位置的文字上点击右键，可通过弹出的右键菜单更改每

个光源。 

 

 

图 6-32 同色异谱及色恒常界面 

 

图 6-33 改变同色异谱及色恒常界面光源个数 



43 

 

 

6.9	Recipe	Formulation	配方配方配方配方计算计算计算计算	

DigiColor提供了配方计算的功能（选配），通过选定一个标准颜色，在相应的测量条件

下，软件按所选的基色进行比例分配，并将符合色差范围的配方显示出来。通过 Color 

Management→Recipe Formulation打开（如图 6-34）。 

 

图 6-34 Recipe Formulation结果界面 

 Job Name：
：：

：  输入自定义名称。 

 Standard：
：：

：  选择数据库中（或测量）的标准颜色。 

Redye Batch：
：：

： 此项为重染色，只有当选择右侧“Redye”选项时，才能在此处从数

据库中选择颜色，将选择的颜色重新染色至标准颜色。 

Normal Match：
：：

： 普通的配方生成。当您只需将所选颜料通过配比到达标准颜色，选择

此项即可。 

Search &Correct：
：：

：查找和修正颜色功能。 

Redye：
：：

：  如果您想将某个指定的颜色重新染色至标准颜色，请选择此项进行配

比。 

Expert Mode：
：：

： 专家模式。 

Customer：
：：

：  此项为用户名称。 

Formulate：
：：

：  选择好基色后，点击此按钮，软件将自动进行配方的计算，结果展示

在下方的表格中。 

Save Recipe：
：：

：  顺利进行配方计算后，软件会点亮此按钮，点击进行配方的保存。 

Blends：
：：

： 此菜单栏可选择 Pure（单一的）配比或者 Blend（混合）配比，当选

择混合配比后，文本框可输入由“Side1”部分所占的比例。该比例表

示“Side1”符合色差标准的配方所提取的染料比例。剩余的比例将由

“Side2”配方中染料的进行分配。 
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图 6-35  Side1选择框 

Side1/Side2：
：：

：   该栏目分别可选择所需的基色，系统将根据所选基色进行配方计算。

当所选基色数量不够或者达不到配色所需的要求时，系统将会提醒您，

对所选的基色进行补充或调整。 

 

图 6-36 设置颜色参数 

Colorimetric parameter：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。通过在“lightness factor”文本框

中输入所需值，可以调整任何公式的“明度权重”参数。若此参数用

于“可接受性”决策的权重色差方程，则在这种情况下，应将其设置

为值 2。如果需要可感知的色差，则参数应设置为 1。Observer建议

为默认选项 10度。
。。

。这是用于色差计算的标准观察者数据。大多数的

标准和颜色测量设定为 10度的观察者数据。一般情况下选择“10”，

除非消费者或者特殊的实验方法一定要设定为“2”。 

 

图 6-37 Match parameter设置界面 

Match parameter：
：：

：在此菜单栏中可以设置配方计算的色差标准等参数。“dE Normal 

Match”为设置正常配方计算模式时的色差标准范围，“dE Accept 

Match”为设置可接受的色差标准范围，“dE Shade Search”为颜色搜

索时的色差标准范围。“Sort by”为选择的数据表的排序依据，可根

据“Metamerism（同色异谱）”或“Cost（成本）”进行排序。“Dye 

Combinations”为配方结果中涉及的颜料种类数目。“Max. No. of 

Recipes”为配方结果界面所允许显示的最大配方数。 

Export parameters：
：：

：此菜单栏为参数的导出。 
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图 6-38配方结果 

配方结果：

配方结果：配方结果：

配方结果： 图 6-38 为配方计算的结果。最左侧的“N1”等符号为所生成的配方

序号。“Concentrations”文本框显示的是配方计算出的染料/颜料的浓

度。“Colour Differences”文本框显示的是在不同光源下配方生成的颜

色与标准颜色之间的色差值及明度、彩度和色调的差异值。

“Reflectance”标签栏下显示的为“标准颜色”和“Side1/Side2配方

颜色”生成的反射率曲线，通过“Scale”您可以对反射率曲线的纵坐

标进行缩放。 

6.10	Match	Correction	配配配配方方方方校正校正校正校正	

DigiColor提供了配方修正的功能（选配），通过选定一个标准颜色，在相应的测量条件

下，软件对所选的已配成的颜色进行校正，再选择将符合色差范围的校正结果显示出来。

通过 Color Management→Match Correction打开（如图 6-39）。 

 

图 6-39 Match Correction操作界面 

 Job Name：
：：

：  输入自定义名称。 

 Standard：
：：

：  此项为选择数据库中的标准颜色。 

Recipe Sample：
：：

： 此项为所选的需校正的原配方。 

Laboratory：
：：

：  说明此次校正是用于实验室研究。 

Production：
：：

：  说明此次校正用于工业生产。 

Expert Mode：
：：

： 专家模式。 

Blends/Batch Wt：
：：

：分别选择配制的比例和总配制质量。 

Correction：
：：

：  选择好染料后，点击此按钮，软件将自动进行配方的校正，结果展示
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在下方的表格中。 

Save Recipe：
：：

：  顺利进行配方校正后，软件会点亮此按钮，点击进行配方的保存。 

Concentration： 此项为选择进行配方校正的染料。将选择数据库中的颜料进行配方校

正。您可以通过“Add Dyestuff”来新增染料，“Delete Dyestuff”来删

除所选的染料。 

 

图 6-40设置颜色参数 

Colorimetric parameter：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。通过在“lightness factor”文本框

中输入所需值，可以调整任何公式的“亮度权重”参数。若此参数用

于“可接受性”决策的权重色差方程，则在这种情况下，应将其设置

为值 2。如果需要可感知的色差，则参数应设置为 1。Observer建议

为默认选项 10级。
。。

。这是用于色差计算的标准观察者数据。大多数的

标准和颜色测量设定为 10级的观察者数据。一般情况下选择“10”，

除非消费者或者特殊的实验方法一定要设定为“2”。 

 

图 6-41 Correction parameter设置界面 

Correction parameter：
：：

：在此菜单栏中可以设置配方校正的色差标准等参数。“dE Normal 

Match”为设置正常配方校正模式时的色差标准范围，“dE Accept 

Match”为设置可接受的色差标准范围，“Add Percentage”为增加百

分数。“Production Correction Method”为用于生产的配方的校正方法，

您可以选择“Auto Correction”进行自动校正并设置自动校正的最大

值，选择“Maximum Yield”最大产量校正并设置最大产量的值，选择

“100%”则将校正全部所定的重量。 

 Export parameters：
：：

：此菜单栏为参数的导出。 
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图 6-42 配方结果 

配方结果：

配方结果：配方结果：

配方结果：以上表格为匹配后的结果。最左侧的“Correction”为校正后的配色。选择

“Print”可将结果进行打印。“Colour Differences”文本框显示的是在

不同光源下校正前的配色和校正后的配色与标准颜色之间的色差值

不同光源下校正前的配色和校正后的配色与标准颜色之间的色差值不同光源下校正前的配色和校正后的配色与标准颜色之间的色差值

不同光源下校正前的配色和校正后的配色与标准颜色之间的色差值

及亮度、色度和色调的差异值。“Concentrations”文本框显示的是配

方计算出的染料的浓度。 “Reflectance”标签栏下显示的为“标准颜

色”和“校正前后配色”生成的波长反射率曲线，通过“Scale”您可

以对反射率曲线的纵坐标进行缩放。 
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7. Color Imaging 彩彩彩彩色色色色图图图图像像像像 

通过 Color Imaging 可以对图像进行测量，读出图像颜色的信息，如颜色三刺激值、表

面纹理、光泽等信息。通过读取图像信息，软件可根据您的需要对图像进行色差分析、颜色

替换、色域检查等处理。 

7.1	Image	pixel	图像像素图像像素图像像素图像像素	

7.1.1 Search & Replace 颜色搜索颜色搜索颜色搜索颜色搜索和和和和替换替换替换替换 

在 Search & Replace中用户可以设置需搜索的目标颜色和搜索标准等，在数据库中查找

对应的颜色，并可对图像颜色进行替换。 

 

图 7-1 Search & Replace设置界面 

选择

选择选择

选择标准

标准标准

标准颜色：

颜色：颜色：

颜色： 

可以利用多种选择工具设定标准颜色。1）通过在 XYZ Color中设置颜色的值；2）加载

数据库中的颜色数据来设定标准颜色；3）也可以勾选“From Image”复选框，然后直接从

图像中获取标准颜色。 

For shades similar to：
：：

： 

From Image:  如果要从图像中选择标准颜色，请选中“From Image”复选框。从图像获

取的标准颜色将在“From”框中显示，颜色选择完成后，取消勾选

“From Image”复选框。 

XYZ Color:    XYZ Color允许您输入 CIE标准颜色坐标。 

Database:   允许您从 DigiColor数据库中选择标准颜色。 

Color spaces (XYZ/CIELAB/RGB)：
：：

：Color spaces决定了在哪个颜色空间中进行纹理映射和

颜色模拟。 

注：要使色彩模拟正确工作，必须进行正确的仪器校准。 
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图 7-2 XYZ Color颜色设定界面                  图 7-3 Database颜色加载界面 

 

Search Criteria：
：：

： 为搜索的标准，在里面可以设置色差公式、明亮度、色度、色调、搜

索范围、分拣的参考指标等参数。符合搜索标准而获得的颜色将出现

在“Searching Result”网格中。 

 

图 7-4公差设定 

Replace Criteria：
：：

：定义了与原始 (From) 颜色相比较的公差范围，在该范围内的像素将

被目标 (To) 颜色替换，软件会对其进行计数和替换。公差设定了亮

度、色度和色调的正负值范围及色差的值。 

Replace： 这将使新颜色替换当前选定的颜色。颜色替换的范围取决于选择的区

域及设定的公差。您可能需要尝试设定不同的公差范围及颜色空间，

以获得最佳效果。 

 

图 7-5查找到的目标颜色界面 
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注：如果在点击 Replace按钮时，“From Image”前的复选框未取消勾选，则软件将在整

个图像中进行“替换”而忽略所选的区域。 

7.1.2 Color replacing 颜色替换颜色替换颜色替换颜色替换  

Color Replace工具允许您选择图像中的特定颜色，并将其替换为其他颜色，同时保留图

像中的纹理细节。使用此工具可以模拟不同颜色对样品外观的影响。 

 

图 7-6 颜色替换界面显示当前光源下的起始颜色及目标颜色 

以

以以

以下是窗口控件选项的说明：

下是窗口控件选项的说明：下是窗口控件选项的说明：

下是窗口控件选项的说明： 

Tolerance:  这可以使您根据 CIELAB颜色空间定义原始（From）颜色公差的范围，

在该颜色范围内，像素将被目标（To）颜色替换。可以根据亮度（L）、

色度（C）和色调（H）的正负值范围及色差来设定公差。 

Select from Image: 此复选框允许从图像中选择“From”或“To”的颜色。选择任一选项

后，在图像中选中所需颜色区域将获得该颜色。选择颜色后，应取消

勾选。 

Color Spaces(XYZ/CIELAB/RGB)：
：：

：Color spaces 决定了在哪个颜色空间中进行纹理映射和

颜色模拟。 

注：要使色彩模拟正确工作，必须进行正确的相机校准。 

XYZ Color：
：：

：  允许您根据 CIE-XYZ坐标指定新的模拟颜色。 

Database：
：：

：  允许您从 DigiColor颜色数据库中选择新颜色。 

RGB Color：
：：

：  允许您使用Windows颜色选择器根据 RGB或 HSL坐标选择新的模拟

颜色。 

Replace： 这将使新颜色替换当前选定的颜色。颜色替换的范围取决于选择的区

域及设定的公差。您可能需要尝试设定不同的公差范围及颜色空间，

以获得最佳效果。 

 注：如果在点击 Replace按钮时，“Select from Image”中的“From”或“To”均未取消

勾选，则软件将在整个图像中进行“替换”而忽略所选的区域。 

7.1.3 Gamut Checking 色域检查色域检查色域检查色域检查 

DigiColor能够检测所选颜色样本是否在一系列的着色剂的色域内。用来向用户表明所选

的颜色在给定的着色剂范围内能否实现，并充当筛选工具。DigiColor通过存储一系列着色剂
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的光谱数据并计算这些着色剂可能达到的色域来实现这一点。 

先设定“Standard color”中的颜色样本（可以勾选“From Image”，从图像中选择所需区

域或者从“Database”加载数据库颜色），再从“Substrate/base”中选择基色，点击 Check进

行色域检测。 

 

图 7-7 Gamut Checking界面 

 

7.1.4 Color Clustering 颜色聚颜色聚颜色聚颜色聚类类类类 

图标：  

Color Clustering允许将图像的选定区域分解（分割）为相似颜色的区域。此外，颜色聚

类在每个聚类中显示像素的百分比，与所选区域每种颜色所占有的百分比相对应。DigiColor

软件根据所选区域中颜色的总数确定每个色类的颜色中心。色心周围的所有像素都包含在集

群中，集群的颜色为所包含的像素颜色的平均。颜色之间的色度越接近，DigiColor软件解析

集群所需的时间就越长。软件可以检索每个集群的颜色数据。 

颜色聚类对于测量图像中颜色的面积或数量是有用的。为了从一个集群中获得准确的颜

色数据，区分不同颜色的间隔（Interval）应该小一点，大约为 5或 6，集群的数量（Cluster）

应相对高一点。 

 

图 7-8颜色聚类结果 

生成颜色

生成颜色生成颜色

生成颜色群集步骤

群集步骤群集步骤

群集步骤：

：：

： 

a. 从图像中选择所需区域； 

b. 选择 Threshold（阈值）、Interval（间隔）和 Cluster（群集数）。 

Threshold：
：：

： 是特定颜色的最小像素数，表示为该颜色的像素包含在群集中所需的
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最小百分数。 

Interval:  决定了每个集群的大小。间隔越小，颜色的宽容度越严，因此包含在

每个群集的像素的颜色变化越小。群集间隔设置的最小值为 5。 

Cluster:  是选定区域将被细分为群集的数目。选择的群集数越多，每个群集中

的颜色就越清晰。如果选择的群集数超过容纳所有像素所需的群集数，

软件将显示一条警告消息，群集数将自动减少。 

c. 单击 Clustering按钮，确定颜色群集。 

注：如果选定区域内的颜色对比度很小，颜色聚类可能需要几分钟才能完成。 

d. 双击任何群集以显示比色数据。 

若要从列表中永久删除群集，请选中要删除的群集，然后按 Delete（删除）按钮。选中

所需的群集并在按住Ctrl键的同时单击“Delete”按钮可以暂时去除任何群集。（CTRL+Delete）

如果通过任一方法删除集群，则将重新计算剩余群集所占的百分比。 

Print:   点击“打印”按钮，可以打印出群集的 CIELAB数据（如图 7-9）。 

 

图 7-9 打印颜色聚类结果 

7.2	Imaging	Measuring	图像测量图像测量图像测量图像测量	

Imaging Measuring与 Spectro Measuring不同，实现从图像中测量颜色的功能。 

Imaging Measuring能够显示所选区域的平均颜色。在颜色图片柜中的灰色背景下（如图

7-10），颜色可根据鼠标右键菜单选择 6种不同的光源之一显示结果。颜色通过设置 Setup→

Option→Camera中的“Illuminant（光源）”和“Observer（观察者）”进行计算。您可以选择

真实色度或色度适应两种不同情况下显示预览颜色，也可以显示、打印、输出或将颜色的光

谱反射率和色度值添加到 DigiColor 数据库中。DigiColor 进行图像选定区域内所有像素的平

均颜色的计算或者进行校正以考虑基色的表面效应。您也可以将测量历史中的所有测量值平

均起来。DigiColor 中的颜色菜单允许访问 DigiColor 自有的颜色质量控制包。一系列传统的

分光光度计可以通过软件连接，测量的光谱数据将存储在 DigiColor的Microsoft SQL数据库

中。光谱数据可用于常规的颜色质量控制或用于图像的重新着色。 

通过 Imaging Measuring可读出图像选定区域不同色彩空间的数值（即 CIE-XYZ, CIE-LAB, 
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CIE-LCH）。并且在右侧以 LAB 三值组成的坐标直观显示在空间坐标系上（如图 7-10）。图像

测量前，可能需要对仪器进行校准，详细情况请参考第 5章 Calibration； 

从图像中选定所需区域，图 7-10 下方表格会自动识别出颜色数目并且在右上方的 LAB

颜色坐标中标出相应颜色点的位置。 

注：如果图像用于颜色测量，则它们必须为

注：如果图像用于颜色测量，则它们必须为注：如果图像用于颜色测量，则它们必须为

注：如果图像用于颜色测量，则它们必须为 RGB TIF格式文件，以便可以访问图像的原
格式文件，以便可以访问图像的原格式文件，以便可以访问图像的原

格式文件，以便可以访问图像的原

始校准数据。

始校准数据。始校准数据。

始校准数据。 

 

图 7-10 Imaging Measuring图像测量界面 

7.3	Measurement	Workflow	

暂时不可使用 

7.4	Imaging	QC	图像质量图像质量图像质量图像质量控制控制控制控制	

与数据库 Quality Control（参见 6.4）不同，Imaging QC可直接实现图像颜色质量控制。 

通过 Imaging QC可以评估在 D65光源下，选定区域（若选中多个颜色，颜色则为选定

区域的平均值）的颜色与 DigiColor 数据库中的着色剂样本数据进行比较。软件界面将显示

两个色块的预览，以及在某一色差公式下，两个颜色的色差大小，并显示色差分析值。 

如果存储的图像用于颜色测量，则它们必须存储为 RGB TIF文件格式，以便可以访问图

像的原始校准数据。 
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图 7-11 Imaging QC图像 QC界面 

 

色差比较分析操作步骤如下：

色差比较分析操作步骤如下：色差比较分析操作步骤如下：

色差比较分析操作步骤如下： 

a. 通过 View，打开“Image QC”窗口，如图 7-11； 

b. 选择色差比较的参照色，有三种方法进行选择： 

 1. 点击 Load按钮，加载数据库中的颜色样本； 

 2. 连接分光光度计，点击Measure进行测量选择； 

 3. 从图像上选择颜色（从图像上选择目标颜色请参考 4.3章节的内容）； 

c. 选完参照色后，开始选择需要进行对比的颜色（同样的，选择目标颜色请参考 4.3

章节的内容）； 

此时，“Illuminant”窗口中的“Color difference in CIELAB”面板中将显示两种颜色的明暗

性及色差比较值。同时，两种颜色的色差值及相关文字描述将显示在“Batches”文本框中。               

“Batches”表会显示明度、彩度、色调、色差四个方面差异的计算结果。右上角是直观

的两者颜色对比，点击 Swap使两个颜色对换（对比色变为参照色，参照色变为对比色），点

击 Plots查看每组颜色的反射率图及由Δa*和Δb*组成的二维坐标图（如图 7-12）。 

 

 
图 7-12反射率图 
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7.5	Texture	Mapping	纹理映射纹理映射纹理映射纹理映射	

图标：  

Texture Mapping（纹理映射）窗口（图 7-13）包含用于从图像中提取纹理信息并将所选

颜色应用于图像或纹理文件的控件。 

 
图 7-13纹理映射界面 

纹理贴图的质量取决于仪器使用的相机类型和照明柜中的照明体。您应该咨询您的

DigiColor应用程序专家，以获得有关生成高质量纹理图像的建议。 

XYZ Color：
：：

： XYZ Color允许您根据 CIE-XYZ坐标指定新的模拟颜色。 

Load：
：：

：  允许您从 DigiColor颜色数据库中选择新颜色。 

RGB Color：
：：

： 允许您使用Windows颜色选择器根据 RGB或HSL坐标选择新的模拟颜色。 

XYZ Map：
：：

： 此按钮将用所选的模拟颜色替换所选区域的颜色。 

进行纹理映射操作步骤如下： 

1. 选择颜色：可通过 XYZ/Load/RGB选择颜色，或者勾选 Image，从图像中选择颜色； 

2. 取消勾选“Image”，在图像上用选择工具选择进行映射的目标区域，点击 XYZ Map. 

您可以选择纹理映射和颜色模拟在哪个颜色空间（XYZ/CIELAB/RGB）中进行。不同的纹

理可能需要不同的颜色空间才能达到最好的效果。 

注：要使颜色模拟正常工作，必须在捕获图像前进行正确的相机校准，并且颜色模拟

必须与纹理贴图位于同一颜色空间中。 

7.6	Color	Sorting	颜色筛选颜色筛选颜色筛选颜色筛选	

Color Sorting允许设定多个标准颜色，使用指定的搜索规则，对所选图像区域中的所有

像素进行搜索。输出是用选定区域的“False Colour（假彩色）”替换相应的像素点，以清楚

地突出显示已替换的像素。此外，所选的标准颜色与指定公差内已筛选的像素之间的 CIELAB

色差值及被替换的像素点百分数将被显示在“Results”中。如果一个像素匹配了多个标准的

选择公差，则根据色差值将其指定给最接近的标准项。 

选择标准颜色：

选择标准颜色：选择标准颜色：

选择标准颜色： 

标准颜色可以点击 Load加载数据库颜色数据。如果要从图像中选择颜色，请选中 Image

按钮，依次选中的颜色都将出现在标准颜色中。选择颜色后，应取消选中 Image. 

Tolerances: 定义了标准颜色的公差范围，在该颜色范围内，像素将被“False Color”

右侧的颜色替换。可以根据明度差（∆L）、彩度差（∆C）、色调差（∆H）

的正负值范围和∆a, ∆b正负值范围及色差来设定公差。 
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False Color:  将用一个随机的颜色替换所选区域在公差范围内的像素点。这可以突

出显示所选区域中哪些像素已匹配标准颜色的公差范围。False Color

后方分别显示随机的 R、G、B三值，根据“Grey”软件将有偏向性地

调节 R、G、B三值。 

Colour Mapping:  此选项选择用于颜色映射的颜色空间。 

Sort by:  软件可以根据用户的选择进行排序，可将选择标准设定为明度差（∆L）、

彩度差（∆C）、色调差（∆H）、∆a, ∆b色差（∆E）其中之一的变化值

大小对结果进行排序。 

Sort:  点击 Sort 按钮运行排序和像素的替换。完成后，在相应公差范围内

的像素点将被重新着色为新的颜色。 

 

图 7-14 颜色筛选结果界面 

结果

结果结果

结果（

（（

（Results）
））

）表：

表：表：

表：结果表（图 7-14）中将分别显示公差范围内的像素与标准颜色之间

的色差值及被替换的像素百分比等信息。 

以下示例可以较好的解释表中的数据：假如我们有一张印刷品的图片，我们想知道印刷

品的颜色是否与我们存储的标准相符。为此，我们通过测量或从数据库中调用标准颜色来设

定标准颜色。因为我们想知道印刷品的颜色与我们的标准有多接近，所以我们需要进行颜色

的筛选替换。这将给出该颜色与标准颜色之间的色差，也将在视觉和数字方面形象地表达色

差。               

这个例子展示了如何使用 Sort 将图像中的颜色与标准颜色或其他颜色进行视觉比较，

并用数字表示颜色差异。通过使用“False Color”输出，您可以使用对比色进行替换。这非

常清楚地说明了在 Sort中包含了哪些像素。如果您需要检测的颜色周围有其它相似的颜色，

则此功能非常有效。 

7.7	Texture	Matrix	 纹理矩阵纹理矩阵纹理矩阵纹理矩阵	

图标：    快捷键：Alt + X 

您可以使用“纹理矩阵”功能评估同一纹理与不同颜色的组合情况。此功能允许您创建

一个“调色板”，其中包含以矩阵形式排列并有着相同纹理的文件。保存的纹理矩阵包含纹

理图像和将要映射到其上的颜色数据。此外，矩阵将计算矩阵中左上角的第一个元素和每个

后续元素之间的 CIELAB色差。               

通过选择 Color Imaging→Texture Matrix 打开纹理矩阵，将出现以下窗口（如图 7-15）： 
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图 7-15纹理矩阵操作界面 

以下是窗口控件的说明：

以下是窗口控件的说明：以下是窗口控件的说明：

以下是窗口控件的说明： 

Row和
和和

和 Column：
：：

： 分别表示“行”和“列”，在“行”和“列”中输入所需的矩阵大小。 

Color Types：
：：

：  该选项用于选择是从数据库中导入矩阵颜色，还是直接输入 CIE颜色

值。 

Double-clicking to：
：：

：此项为双击确定矩阵元素实现更改颜色数据还是更改颜色名称的功

能。 

Mapping spaces：
：：

： 确定将选定颜色映射到纹理矩阵的颜色空间。CIELAB 是推荐使用的

默认颜色空间。 

Save matrix image：
：：

：此按钮用于保存矩阵图像。保存矩阵图像时，屏幕上只显示原始的

未着色矩阵。您需要预览矩阵或重新打开图像以查看完全重新着色的

矩阵。 

Save QTX：
：：

：  此按钮以 QTX文件形式保存矩阵图像。 

Preview Matrix：
：：

： 用于显示带有所选颜色数据的全彩色映射矩阵。使用纹理矩阵之前，

最好先选好待着色的图像或部分图像，点击 Preview Matrix按钮可按

定义的矩阵颜色对图像进行着色（如图 7-16所示） 

OK：
：：

：   此按钮用于关闭“纹理矩阵”对话框而不保存矩阵。 

 
图 7-16 纹理矩阵着色效果图 
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7.7.1 创建纹理矩阵创建纹理矩阵创建纹理矩阵创建纹理矩阵            

以下为创建纹理矩阵的步骤：

以下为创建纹理矩阵的步骤：以下为创建纹理矩阵的步骤：

以下为创建纹理矩阵的步骤： 

a. 打开一张您将要映射颜色的包含纹理的图像；  

b. 在该图像上选择一个需映射颜色的区域。这个选择的区域将成为矩阵图像。尽管可

以使用任何类型的选择工具，但我们建议使用矩形工具来选定纹理区域；  

c. 通过选择 Color Imaging→Texture Matrix，打开“纹理矩阵”对话框；  

d. 设定“Row”，“Column”的行和列值来定义矩阵的大小、形状；  

e. 选择颜色的加载方式。颜色可以从数据库中获取，也可以从 XYZ颜色选择对话框中

手动输入； 

f. 选择“Double-clicking to”中的“Change colors”（此时双击矩阵可对颜色值进行修

改）； 

g. 在“Mapping spaces”中选定用于映射至矩阵图像的颜色的空间。我们推荐使用

CIELAB颜色空间； 

h. 双击要更改的矩阵元素。根据所选的“Color Types”（颜色类型）选项，软件将打开

“XYZ Colors”（手动输入）或者“Database”（从数据库选择）对话框； 

i. 选择您需要的颜色，并关闭选择对话框。如果选择的是数据库中的颜色，则颜色名

称将自动添加到矩阵元素中； 

j. 对矩阵中的每个元素重复步骤（i）；  

k. 单击“Preview Matrix”按钮可以预览矩阵；  

l. 通过单击“Save matrix image”按钮保存纹理矩阵。请务必将纹理矩阵保存为 RGB TIF

格式文件。 

7.7.2 编辑纹理矩阵编辑纹理矩阵编辑纹理矩阵编辑纹理矩阵 

通过重新打开矩阵图像，您可以编辑纹理矩阵中的矩阵维度和元素的颜色或名称。之前

已设置好的选项将决定重新打开纹理矩阵时的状态。 

以下为编辑或修改纹理矩阵的步骤：

以下为编辑或修改纹理矩阵的步骤：以下为编辑或修改纹理矩阵的步骤：

以下为编辑或修改纹理矩阵的步骤： 

a. 打开纹理矩阵图像； 

b. 软件提示 “This is a Texture Matrix Image, re-colour it（这是纹理矩阵图像，是否对其

重新上色）?” 若单击“NO”按钮，“纹理矩阵”对话框将打开，显示矩阵中的颜色； 

c. 若要更改矩阵元素的颜色名称，请选中“Change names”，然后双击要编辑的矩阵元

素；  

d. 在文本框中输入新名称，然后单击“确定”按钮； 

e. 若要更改元素的颜色，请选中“Change colors”，然后双击要更改的元素； 

f. 更改或编辑元素的颜色； 

g. 通过单击“Save matrix image”按钮保存对矩阵的修改。 
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7.8	QC	Matrix	 颜色质量颜色质量颜色质量颜色质量管理管理管理管理矩阵矩阵矩阵矩阵	

图标：  

您可以使用“质量管理矩阵”功能测试多样本组与标准颜色之间的色差对比情况。此功

能允许您创建一个“调色板”，其中包含以矩阵形式排列的两列颜色数据，第一列为标准颜

色的数据，第二列为对比的样本颜色数据。根据所设定的参数标准，通过颜色对比，软件将

判定每个对照组的色差结果。保存的 QC矩阵图像包含图像矩阵的颜色数据。  

通过选择 Color Imaging→QC Matrix打开纹理矩阵，将出现以下窗口（图 7-17）： 

 

图 7-17 QC矩阵操作界面 

点击More >>将出现以下窗口（图 7-18）： 

 

图 7-18 QC矩阵参数设置界面 

以下是窗口控件的说明：

以下是窗口控件的说明：以下是窗口控件的说明：

以下是窗口控件的说明： 

Double-clicking to: 此项为双击确定矩阵元素实现更改颜色数据还是更改颜色名称的功

能。 

Mapping spaces：
：：

： 确定将选定颜色映射到纹理矩阵的颜色空间。CIELAB 是推荐使用的

默认颜色空间。 
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Mirror：
：：

： 勾选此选项将原始

原始原始

原始图像转换为其镜像，就如同镜子沿着图像的左侧边

缘垂直放置的一样。 

Save image：
：：

： 此按钮用于保存矩阵图像。保存矩阵图像时，屏幕上只显示原始的未

着色矩阵。您需要预览矩阵或重新打开图像以查看完全重新着色的矩

阵。只有在所有矩阵元素加载了颜色数据，此功能才能使用。 

Save QTX：
：：

： 此按钮以 QTX文件形式保存矩阵图像。 

New Matrix：
：：

： 重新新建

新建新建

新建矩阵对照组，之前的矩阵将被清除。 

Preview：
：：

： 用于显示带有所选颜色数据的全彩色映射矩阵。只有在所有矩阵元素

加载了颜色数据，此功能才能使用。效果图如图 7-19所示。 

Insert：
：：

： 此按钮用于在 QC矩阵中尾部插入新增一行对照组。 

Remove：
：：

： 此按钮用于删除所选的一组对照组。 

Hide QC：
：：

： 此按钮用于隐藏右侧的 QC矩阵色差数据窗口。 

Print QC：
：：

： 此按钮

按钮按钮

按钮用于打印 QC数据。只有在所有矩阵元素加载了颜色数据，此

功能才能使用。 

OK：
：：

： 此按钮用于关闭“QC矩阵”对话框而不保存矩阵。 

Primary Illuminant（
（（

（D65）：
）：）：

）：此栏目内容显示在主要的 D65光源下，所选对照组颜色的相

关文字描述。 

Metamerism Check：
：：

：此栏目可以选择不同光源下，所选的对照组颜色的直观的视觉变化。

即对照组颜色随着所选的光源的不同，显示出不同的颜色。 

Pass/Fail：
：：

：        此栏目用于显示所选的对照组在不同的光源下的色差。显示亮度（L）、

色度（C）、色调（H）、色差（E）的差异值。当这四个差异值都在Tolerances

规定的范围内时，其数据左边的相应红色底色将变为绿色（意为通过）。

当 D65 光源下数据为通过时，Primary Illuminant（D65）中红色底色

的“FAIL”将变为绿色底色的“PASS”。 

Editable from another user：
：：

：勾选此选项表示可编辑从其他用户来的 QC矩阵。取消勾选

则为不可编辑。 

Export：
：：

： 以 QTX文件格式输出 QC矩阵。 

Log batch：
：：

： 保存一批到日志文件。 

Create new log：
：：

： 创建新日志。 

Colorimetric parameters：
：：

：此栏目为颜色参数设置。在其中可以选择需要的色差公式，选

择不同的光源及不同的观察者视场。通过在“kL”文本框中输入所需

值，可以调整任何公式的“亮度权重”参数。若此参数用于“可接受

性”决策的权重色差方程，则在这种情况下，应将其设置为值 2。如

果需要可感知的色差，则参数应设置为 1。 

Tolerances: Tolerances定义了标准颜色的公差范围。符合该颜色范围的对照组，将被软

件认定为“PASS”。可以根据亮度（L）、色度（C）、色调（H）的正负

值范围和ΔE（色差）来设定公差。 

Batch Ordered by：
：：

：根据方框中所选的参数对 QC矩阵中的对照组的颜色进行排序，更换

其行数。可以选择从色差、色调、光源变化产生的同色异谱程度及颜

色的名称进行排序。选择 None则取消排序。 

Save STD：
：：

： 保存颜色标准及公差范围至数据库。 

Save BAT：
：：

：  批量保存颜色标准及公差范围至数据库。 
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图 7-19 QC矩阵着色效果图 

7.8.1 创建创建创建创建 QC矩阵矩阵矩阵矩阵 

以

以以

以下为创建

下为创建下为创建

下为创建 QC矩阵的步骤：
矩阵的步骤：矩阵的步骤：

矩阵的步骤： 

a. 打开一张目标图像；  

b. 在该图像上选择一个需映射颜色的区域。这个选择的区域将成为矩阵图像。尽管可

以使用任何类型的选择工具，但我们建议使用矩形工具来选定纹理区域；  

c. 通过选择 Color Imaging→QC Matrix，打开“QC矩阵”对话框； 

d. 点击 Insert插入新增您所需的矩阵组；  

e. 选择“Double-clicking to”中的“Change colors”（此时双击矩阵可对颜色值进行修

改）； 

f. 在“Mapping spaces”中选定用于映射至矩阵图像的颜色的空间。我们推荐使用

CIELAB颜色空间； 

g. 双击矩阵第一列要更改的矩阵元素。软件将打开从数据库选择颜色的对话框。此时

选择您需要的标准颜色，并关闭选择对话框，颜色名称将自动添加到矩阵元素中； 

h. 双击矩阵第二列要更改的矩阵元素。软件将打开从数据库选择颜色的对话框。此时

选择您需要的对照颜色，并关闭选择对话框，颜色名称将自动添加到矩阵元素中； 

i. 对矩阵中第二列的其它元素重复步骤（h）； 

j. 点击 More >> 进行参数设置，并设置好所需的“Tolerances（公差）”范围、“Batch 

Ordered by（排序参照）”等数据； 

k. 单击“Preview Matrix”按钮可以预览矩阵； 

l. 通过单击“Save image”按钮保存 QC矩阵。请务必将 QC矩阵保存为 RGB TIF格式

文件。 

7.9	Advance	Clustering高级高级高级高级聚类聚类聚类聚类分析分析分析分析	

Advance Clustering（高级聚类分析）是 7.1.4 Color Clustering（颜色聚类）的扩展版本。

在高级聚类分析中，用户无需选择聚类分析的各种参数，就可对选定的图像区域进行初步的

聚类分析。高级聚类分析可自动将图像中的所有颜色按相似程度分割成不超过 8类，并给出
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每个聚类中像素的百分比，与所选区域每种颜色所占有的百分比相对应。与 Color Clustering

相似，Advance Clustering 根据所选区域中颜色的总数确定每个色类的颜色中心。色心周围

的所有像素都包含在集群中，集群的颜色为所包含的像素颜色的平均。 

通过选择 Color Imaging→Advance Clustering或 View→Advance Clustering打开“高级聚

类分析”操作窗口（如图 7-20）。Advance Clustering分为 Auto Clustering（自动聚类）和Manual 

Clustering（手动聚类）两大方法。 

 

 
图 7-20 高级（自动）聚类窗口 

以下是窗口控件的说明：

以下是窗口控件的说明：以下是窗口控件的说明：

以下是窗口控件的说明： 

Return to MANUAL：
：：

：表明目前采用的方法为 Auto Clustering（自动聚类），点击该按钮可

以改变成采用Manual Clustering（手动聚类）方法，此时会清除自动

聚类的结果，按钮的文字编程 Return to AUTO，进入手动聚类状态（如

图 7-21）。 

 
图 7-21 进入手动聚类状态 

Check Original：
：：

： 该按钮只有在完成一次自动或手动聚类分析之后，才处于可用状态。

点击处于

处于处于

处于可

可可

可用

用用

用状态

状态状态

状态的

的的

的该按钮，可查看聚类之前的图像，同时，该按钮

的文字变成 Check Effect（如图 7-22）；再次点击该按钮，可查看聚类

分析效果图像，按钮文字变回 Check Original状态。 

 
图 7-22 查看原始图像之后的窗口 

Clear Table：
：：

： 该按钮只有在完成一次自动或手动聚类分析之后，才处于可用状态。

点击处于

处于处于

处于可用

可用可用

可用状态

状态状态

状态的

的的

的该按钮，可清除颜色列表和图像聚类效果，恢复

到聚类之前的状态，并且按钮处于不可用状态。 

Auto Clustering：
：：

： 该按钮只有在处于自动聚类方法时，才处于可用状态。点击处于
处于处于

处于可

可可

可用

用用

用
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状态

状态状态

状态的

的的

的该按钮，可自动进行聚类分析，完成后按钮不可用状态（如图

7-20）。自动聚类分析方法和步骤见 7.9.1 

Manual Clustering：
：：

：该按钮只有在处于手动聚类方法时，才处于可用状态。点击处于

处于处于

处于可

可可

可

用

用用

用状态

状态状态

状态的

的的

的该按钮，可进行手工聚类分析，完成后按钮不可用状态（如

图 7-20）。自动聚类分析方法和步骤见 7.9.2 

Print：
：：

： 点击该按钮可打印输出聚类分析结果（如图 7-23）。其中包括图像文

件路径、名称，聚类分析日期，大致颜色外观，CIELAB L*a*b*值（括

号内）以及百分比等信息。 

 

图 7-23 聚类分析打印结果 

 

7.9.1 Auto Clustering自动自动自动自动聚类聚类聚类聚类分析分析分析分析            

以下为

以下为以下为

以下为自动聚类分析

自动聚类分析自动聚类分析

自动聚类分析的

的的

的方法

方法方法

方法和

和和

和步骤：

步骤：步骤：

步骤： 

a. 打开一幅目标图像；  

b. 在该图像上选择一个需聚类分析的区域。选择图像区域时可以使用任何类型的选择

工具；  

c. 通过选择 Color Imaging→Advance Clustering，打开“高级聚类分析”操作窗口（如

图 7-20）； 

d. 确保 Return to MANUAL而不是 Return to AUTO处于显示状态。如果显示的是 Return 

to AUTO，点击 Return to AUTO可恢复到自动聚类分析方法；  
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e. 点击 Auto Clustering可开始自动聚类分析。如果分析完成，聚类的颜色及其在选定

区域的占比将显示在颜色表格中（如图 7-20）。 

7.9.2 Manual Clustering手手手手动动动动聚类聚类聚类聚类分析分析分析分析            

以下为

以下为以下为

以下为手

手手

手动聚类分析

动聚类分析动聚类分析

动聚类分析的

的的

的方法

方法方法

方法和

和和

和步骤：

步骤：步骤：

步骤： 

a. 打开一幅目标图像；  

b. 在该图像上选择一个需聚类分析的区域。选择图像区域时可以使用任何类型的选择

工具；  

c. 通过选择 Color Imaging→Advance Clustering，打开“高级聚类分析”操作窗口（如

图 7-20）； 

d. 确保 Return to AUTO而不是 Return to MANUAL处于显示状态。如果显示的是 Return 

to MANUAL，点击 Return to MANUAL可恢复到手动聚类分析方法，鼠标指针变成吸

管状态 ；  

e. 在选定的图像区域内，肉眼观察分析颜色的种类，点击有代表性的颜色作为聚类颜

色种子。例如 5 种占比较大的颜色（包括背景），一一选取对应的 5 种颜色（如图

24所示），此时每种颜色无占比比例； 

 
图 7-24 手动选择种子颜色之后的窗口，此时颜色无占比大小 

f. 点击Manual Clustering可开始手动聚类分析。分析完成，种子颜色在选定区域的占

比将显示在颜色表格中（如图 7-25）。 

 
图 7-25 手动聚类分析结果 

7.9.3聚类聚类聚类聚类分析分析分析分析结果结果结果结果核核核核查查查查及及及及微调微调微调微调            

图像像素核查：按下键盘 Shift键，同时点击 Advance Clustering（高级聚类分析）后色

表中某个颜色，对应图像中归入该类颜色的所有像素均以白色显示，其他类别颜色保持不变。 

微调：在 Advance Clustering（高级聚类分析）后色表中某个颜色任意位置处按下鼠标左

键并拖动鼠标到另一个颜色上，可将该颜色归入到目标颜色类中，从而减少分类类别数目和

去除占比较小的颜色类别。该微调功能可用于聚类结果中某类占比极小又有另一相似颜色的
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情况下，微调聚类结果。 

 

7.10	Color	for	mapping	颜色映射空间颜色映射空间颜色映射空间颜色映射空间	

此处有三个颜色映射空间供您选择：

此处有三个颜色映射空间供您选择：此处有三个颜色映射空间供您选择：

此处有三个颜色映射空间供您选择： 

1. XYZ Color：
：：

：允许您根据 CIE-XYZ 坐标指定新的模拟颜色。根据手动输入

XYZ/La*b*/Lc*h的值来设定颜色。 

2. RGB Color：
：：

：允许您使用Windows颜色选择器根据 RGB或 HSL坐标选择新的模拟颜

色。 

3. Database Color：
：：

：允许你从数据库中导出颜色数据。 
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8. Image 图像菜单图像菜单图像菜单图像菜单 

此菜单栏有着影响图像整体或部分的外观的功能。 

8.1	常用操作常用操作常用操作常用操作	

8.1.1 Mirror 镜像镜像镜像镜像 

将原始图像转换成它的镜像，就好像是镜子沿着图像的左边垂直放置对原始图像进行成

像。 

8.1.2 Flip 翻转翻转翻转翻转 

使图像围绕图像的中心旋转 180°。 

8.1.3 Negative 负片负片负片负片 

将图像中的每个像素转换成相反的颜色。例如黑色像素显示白色，白色显示黑色，黄色

像素显示蓝色。 

8.1.4 Rotate 旋转旋转旋转旋转 

将按照指定的角度旋转图像，指定一个正数使图像顺时针旋转，一个负数使图像逆时针

旋转。软件的默认设置值是-90度，这将使图像逆时针旋转 90度。 

8.1.5 Resize 调整尺寸调整尺寸调整尺寸调整尺寸 

 

图 8-1调整图像尺寸界面 

根据像素将图像调整到新的尺寸，当前图像的大小（以像素为单位）显示在“调整大小”

对话框中，您可以为图像输入新的尺寸（以像素为单位）。 
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New X Y：
：：

：  图像所需要的新尺寸。 

Scale：
：：

：   确定缩放的百分比。 

Constrain Proportion：
：：

：这可以保持像素的宽高比，改变 X或 Y像素值将按比例自动更改

其它值。 

调整的算法：

调整的算法：调整的算法：

调整的算法： 算法决定了像素是如何从图像中添加或删除的。有“Nearest Pixel”，

“Bilinear”，“Bicubic”算法，我们建议使用“Bicubic”算法。 

注：调整图像大小可能会导致某些像素的 RGB 值发生变化。这可能会导致新图像的颜

色测量和原来图像不同。在可能的情况下，调整大小之前对原始图像进行颜色评估。 

8.1.6 Denoise 降噪降噪降噪降噪  

对图像进行不同程度的降噪处理。可选择的降噪方法有Median（中值）滤波、Blur（均

值）滤波、Gaussian（高斯）滤波。 

Median（中值）滤波：
（中值）滤波：（中值）滤波：

（中值）滤波：中值滤波法是一种非线性平滑技术，它将每一像素点的灰度值设

置为该点某邻域窗口内的所有像素点灰度值的中值，在图像处理中，常用于保护边缘信息，

是经典的平滑噪声的方法。原理是把数字图像或数字序列中一点的值用该点的一个邻域中各

点值的中值代替，让周围的像素值接近真实值，从而消除孤立的噪声点。 

该方法忽略了像素点间的相关性，当目标图像细节纹理复杂时，中值滤波的结果会破坏

其部分纹理。该方法不适合处理高斯噪声，但处理离散的点噪声效果明显，对消除椒盐噪声

（黑白相间亮暗点）非常有效，在光学测量条纹图像的相位分析处理方法中有特殊作用，但

在条纹中心分析方法中作用不大。 

Blur（均值）滤波：
（均值）滤波：（均值）滤波：

（均值）滤波：均值滤波是典型的线性滤波算法，它是指在图像上对目标像素给一

个模板，该模板包括了其周围的临近像素（以目标象素为中心的周围 n个像素，构成一个滤

波模板，即去掉目标像素本身），再用模板中的全体像素的平均值来代替原来像素值。 

均值滤波本身存在着固有的缺陷，即它不能很好地保护图像细节，在图像去噪的同时也

破坏了图像的细节部分，从而使图像变得模糊，不能很好地去除噪声点。此法适用于去除通

过扫描得到的图像中的颗粒噪声。 

Gaussian（高斯）滤波
（高斯）滤波（高斯）滤波

（高斯）滤波：

：：

：高斯滤波是一种线性平滑滤波，适用于消除高斯噪声，广泛应

用于图像处理的减噪过程。通俗的讲，高斯滤波就是对整幅图像进行加权平均的过程，每一

个像素点的值，都由其本身和邻域内的其他像素值经过加权平均后得到，越靠近邻域中心，

权值越大。高斯滤波的具体操作是：用一个模板（或称卷积、掩模）扫描图像中的每一个像

素，用模板确定的邻域内像素的加权平均灰度值去替代模板中心像素点的值。DigiColor提供

了高斯降噪“3*3”及“5*5”两种常用的模板。图像大多数噪声均属于高斯噪声，因此高斯

滤波应用也较广泛。 

 高斯滤波既能平滑噪声，也能保留图像的整体灰度分布特征。高斯滤波公式是各向同

性扩散方程，在图像边缘处沿切向和法向是同等扩散的，所以绝大多数边缘和细节纹理特征

被模糊掉，损失了大量的信息。高斯滤波适合处理均值为零的高斯噪声，但处理离散的点噪

声时，会损失大量细节信息。 

各个噪声方法均有其优点及不足之处，请选择您所需的降噪方法，以达到最佳的降噪效

果。 
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8.1.7 Background removal 背景移除背景移除背景移除背景移除 

可对图像的亮度、饱和度、色调进行自定义调整，分别移除像素更深或更浅的部分。

“Adjust Level”可设置相应项目的黑白程度。例如图 8-2中，将偏亮的背景按明度水平高于

150为阈值移除。 

 

图 8-2 Background removal操作界面 

8.1.8 Zoom 缩放缩放缩放缩放 

此功能为图像进行放大或缩小。 

Zoom in：
：：

： 每次点击都以固定的倍数对图像进行放大（Ctrl+）。 

Zoom out：
：：

： 每次点击都以固定的倍数对图像进行缩小（Ctrl-）。 

Zoom 1:1：
：：

： 点击此项将图像放大一倍（相对于原始大小）。 

Zoom to fit：
：：

： 将图像调整至符合屏幕大小的尺寸。 

8.1.9 Batch RGB 批量批量批量批量 RGB 

允许在多个图像上执行相机 RGB到显示器的 RGB转换。可以设置一个扩展文件名，此

扩展名将自动添加到所有已处理的文件中，并可用于文件标识和跟踪目的。  

8.1.10 Monitor RGB 显示显示显示显示器器器器 RGB 

此选项是使用当前显示器校准数据，将摄像机 RGB图像转换为显示器 RGB图像，这个

功能是对所选的整张图像进行转换，软件不会对图像中的选择区域进行转换。 

注

注注

注意

意意

意：

：：

：不能重复对一幅图进行显示器

不能重复对一幅图进行显示器不能重复对一幅图进行显示器

不能重复对一幅图进行显示器 RGB 转换。
转换。转换。

转换。将此

将此将此

将此功能

功能功能

功能应用于已转换的图像，将导

应用于已转换的图像，将导应用于已转换的图像，将导

应用于已转换的图像，将导

致图像中的颜色显示不正确。

致图像中的颜色显示不正确。致图像中的颜色显示不正确。

致图像中的颜色显示不正确。 

8.1.11 Chromatic Adaptation 色适应性色适应性色适应性色适应性  

此选项为在选定的光源中模拟图像选定区域的外观。建议在图像进行色适应性测试前，

对整幅图像进行校正或者把将进行色适应性测试的感兴趣的区域裁切出来，否则色适应性测
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试区域和非测试区域同时存在的对比度会影响您对图像原本的实际颜色进行判断。选定区域

的色适应性模拟外观的适应程度由 Setup→Option→Image中的相关参数确定。 

8.1.12 Color Gamut Testing 色域检测色域检测色域检测色域检测 

此功能将所选区域超出规定色域范围的像素以特定的颜色突出显示并统计其个数。突出

显示的颜色通过 Setup→Option→Image设置。 

注意：如果在上述设置中将突出的颜色选择了“Closest”，则在图像中可能看不出哪些

像素超出了色域，因为它们被映射到了最接近的颜色。我们建议在进行色域测试之前选择原

色。 

使用工具栏中的选择工具，在图中选择所需区域，此选项会检测区域中有多少像素在色

域外（如图 8-3）。 

 

图 8-3色域检测结果 

8.1.13 Uniformity Testing 均匀性检测均匀性检测均匀性检测均匀性检测 

测试图像中某个区域的照明均匀性，均匀性的输出是用一个图形表示。此选项仅在所选

区域的颜色合理一致时提供可靠的信息，因为它旨在表明所关注的一个相同区域的颜色一致

性。 

8.1.14 Uniformity Correction 均匀性校正均匀性校正均匀性校正均匀性校正 

对捕获的图像进行照明均匀性校正。在对图像进行颜色测量之前，应对图像进行均匀性

校正，以纠正因不均匀照明和镜头渐晕导致的测量误差。要执行均匀性校正，必须将已捕获

的标准白板图像自动加载到正确的文件中（参见 Setup→Option→Camera）。如有必要，均匀

性校正将修改来自照相机的输出像素，以校正图像内的任何不均匀性。我们建议在进行均匀

性校正后保存图像。 

仪器与计算机连接后，每测量一个图像样本前或仪器校准前，需进行颜色均匀性校正，

步骤如下： 
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1. 打开 Setup→
→→

→Option, 在 Camera 标签栏中找到 Spatial Uniformity Correction, 勾选

Automatic uniformity correction。 

2. 在照明柜中的规定范围内放置标准白板； 

3. 点击 Capture White按钮捕获白板图像（图像自动存为 Tif文件格式），白板图像文

件名将自动填入图 8-4中“
““

“Uniformity image”文本框，用于颜色均匀性校正。如果

Automatic uniformity correction一直保持勾选状态（如图 8-4），则随后拍摄的图像

都将自动实现非均匀性校正。 

 

图 8-4颜色均匀性校正设置界面（图中底部） 

注

注注

注意

意意

意：

：：

：不能重复对一幅图进行非均匀性校正。

不能重复对一幅图进行非均匀性校正。不能重复对一幅图进行非均匀性校正。

不能重复对一幅图进行非均匀性校正。将此功能应用于已

将此功能应用于已将此功能应用于已

将此功能应用于已校正

校正校正

校正的图像，将导致图

的图像，将导致图的图像，将导致图

的图像，将导致图

像中的颜色显示不正确。

像中的颜色显示不正确。像中的颜色显示不正确。

像中的颜色显示不正确。 

8.1.15 Image Info 图像信息图像信息图像信息图像信息 

该选项可以选择查看图像的相关信息（如图 8-5）。 

Exif info：   显示任何编译到 Exif标准的图像文件的 Exif信息。 

Multispectral Image： 多光谱图像信息。 

Fastness Grade：  色牢度信息。 

Light Fastness Grade： 耐光色牢度信息。 

Pilling Grade：  起球等级信息。 

Texture Matrix：  纹理矩阵信息。 

QC Matrix：   图像质量管理矩阵。 
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图 8-5图像信息查看界面 
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9. Options 选项设置选项设置选项设置选项设置 

 通过 Setup→Options打开 DigiColor选项设置。 

9.1	Monitor	Options	显示显示显示显示器选项器选项器选项器选项	

Monitor选项标签包含 DigiColor背景颜色和图像对比度的设置（如图 9-1）。 

 

 

图 9-1 显示器选项标签 

Calibrated：
：：

：  方框显示监视器校准的最近日期与时间。 

Background 

 建议设置为 N5。 

 此选项设置 DigiColor的灰色背景颜色。选项有 N5（中等灰度
中等灰度中等灰度

中等灰度）、N7（低灰度）、5574（一

些零售商用的灰度）。一般的，建议为默认的 N5。 

Contrast 

 建议设置为 Normal。 

 此项设置监视器校准的图像的对比度。在一些少数情况下，可能需要通过增强对比度来

凸显图像中的阴影细节。然而，设置过高的对比度会导致颜色超出色域范围，使图像失真。

因此，我们建议设置为默认的 Normal。 
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9.2	Camera	Options	相机相机相机相机选项选项选项选项	

 Camera 选项标签包含相机（仪器）校准、校准的光源及观察者等配置数据（如图 9-2）。 

 

图 9-2 Camera选项标签 

Chart Location 

Chart Location中的 3 个设置选项用来定位相机校准时标准色卡中单个颜色小方格。利

用这些参数软件可以自动定位到色块方格。这些数据一旦确定，一般不去改变它们，除非镜

头类型或相机位置发生改变。 

Min和
和和

和Max数值
数值数值

数值 

 这些涉及相机校准图上单个颜色小方格的大小，以像素为单位。这两个值的设置必须在

小方格的尺寸上细微的上下调整。如果设置不正确，软件将不能定位到校准的方格，您必须

修改设置再次去校准。 

Tolerance 

 建议默认值为 12 

 这决定了当软件试图在校准图表上定位彩色正方形时颜色相似程度，该参数会影响到软

件在校准图表上定位颜色方格时尺寸的变化。这个数值设置的太低可能导致软件定位不到校

准的方格。 

9.2.1 设定设定设定设定Min和和和和Max 

设定最大最小值用于定位相机校准

设定最大最小值用于定位相机校准设定最大最小值用于定位相机校准

设定最大最小值用于定位相机校准色卡

色卡色卡

色卡，以下为操作步骤

，以下为操作步骤，以下为操作步骤

，以下为操作步骤（如图

（如图（如图

（如图 9-3）
））

）：

：：

： 

a. 拍摄一张标准色卡图像； 

b. 选择矩形选择工具； 
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c. 沿着其中一个白方格外部选中一个区域； 

d. 方格的尺寸显示在 DigiColor工具栏下方，比如 S：（65*65）； 

e. 以上尺寸“+5”的值作为最大值，“-20”的值作为最小值。 

 

图 9-3设定Min和Max操作步骤 

Illuminant 

建议默认选项为 D65 

 这是照明柜中用于色差计算的首选光源。通常这个选项是 D65，只有当照明柜中的光源

改变，这个光源类型才跟着改变。 

Observer 

建议默认选项为 10级 

这是用于色差计算的标准观察者数据。大多数的标准和颜色测量设定为 10级的观察者

数据。一般情况下选择“10”，除非消费者或者特殊的实验方法一定要设定为“2”。 

注：如果您改变了光源或者观察者设置，在进行颜色测试之前您必须重新校准相机。 

Calibration Interval 

 此项为仪器校准间隔，建议为默认值 4小时。 

Last Calibration 

 当作完一次仪器校准时，时间及日期将被记录并显示在此对话框中。同时，用于校准的

图像的地址同样也会显示在对话框中。 

注：DigiColor 将为每个校准保存简要记录。这些信息保存在 DigiColor 文件夹的

CalibrationLog.txt文件中。 

Chart type 

 这是用于校准相机的图标类型。本仪器使用 ScoColor 1.0版标准色卡。DigiColor还可以

为特殊的应用使用不同的色卡，但标准的 DigiColor 系统没有提供这些额外的色卡，并且标

准软件不会识别这些图表。如果需要使用特殊的色卡，请与供应商联系。 

在下拉框可以选择您所需的标准色卡类型用来校准相机（仪器）。 

Showing camera settings before releasing Image 

 勾选此选项将阻止显示“相机控制”对话框，然后使用当前相机设置来捕获图像。当您

不想某个用户选择其它不同的相机设置，这个选项很有用。 

Spatial uniformity Correction  

 这个选项用于显示空间均匀性校正的白图的位置。通过 Image→Uniformity Correction打
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开均匀性校正应用程序。在没有指定白图的前提下不能执行均匀性修正。 

Uniformity image 

 此项为用于照明均匀性校正的图片。点击“浏览”按键打开文件。 

9.3	Image	Options	图像选项图像选项图像选项图像选项	

 通过 Setup→Options→Image打开设置（如图 9-4），这些选项将影响色域和色适应性。 

 

图 9-4 Image选项设置页面 

Out of Gamut indication 

 建议默认设置为 Closest。 

 这是将超出色域之外的像素点突出显示的颜色，应用于色域检测和颜色替换功能。 

Beep if current pixel is out of gamut 

 建议默认设置为 Unchecked（不勾选）
（不勾选）（不勾选）

（不勾选） 

 选中这个设置后，当某个像素值超出色域范围了，软件会发出“beep”的响声。 

Maximum Undo Level 

 建议默认设置为 20。 

 这个数字为每个图像可撤销的操作步数。 

注：设置过多的可撤销操作步数意味着需要存储更多的步骤，可能会影响到软件性能。 

Degree of Chromatic Adaptation Transform 

 建议默认设置为 0.35。 

 此项决定了在不同光源下，模拟所选区域外观的变化程度。 

Show first if data exists 

 这个选项被选中后（变为绿色的√），在打开图像时，任何包含 DigiColor数据的 Tiff图

像将自动显示数据。 
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Data to be copied 

 在复选框选中您想存到图像上的数据。 

9.4	Measurement	Options测量选项测量选项测量选项测量选项	

 Measurement Options（如图 9-5）可以自定义“Titre（滴定度）”评价管理及“Ganz Whiteness

（甘茨白度）”参数设置。“Prefix of measured sample”为样本名称添加的前缀，可以设定为

某个字母。 

 

图 9-5测量参数设置 

9.4.1 Titre Manager 滴定管理滴定管理滴定管理滴定管理 

 通过 Setup→Options→Measurement打开Measurement窗口，找到 Titre Manager区。 

 Row：
：：

：  设置滴定的行数。 

 Column：
：：

： 设置滴定的列数。 

 Output：
：：

：  将滴定检测的结果输出。您可以自定义文件名及文件位置。 

Titre：
：：

： 将所设置的滴定行数和滴定列数等参数进行保存或者删除，下拉菜单选

择所需的设置。 

滴定

滴定滴定

滴定测量

测量测量

测量步骤：

步骤：步骤：

步骤： 

1. 打开一个待测的图像或捕获样本图像； 

2. 通过 Setup→Options→Measurement打开设置界面； 

3. 在“Titre”中直接选择所需的设置或者直接在“Row”和“Column”中输入行数列

数再保存新增一个设置； 
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4. 点击 Output输出检测结果表，您可以自定义文件名及文件位置； 

5. 以上设置好之后点击窗口底部的“确定”键进行保存； 

6. 点击工具栏中的“ ”，再在图像上选择测量的区域，图像上会显示横竖排列的“红

圈”（红圈数量取决于设定的行列数）。如果出现的红圈偏离所需的测试范围，请重

新进行区域选择； 

7. 测量结果的文件将自动在“Output”设置的路径中显示。 

9.4.2 Ganz Whiteness 甘茨白度甘茨白度甘茨白度甘茨白度 

白度是物体特殊的颜色属性。白度的量化与明度和无色调密切相关。最初的想法是通过

唯一的数字来表征白度，如今只有在定义了优先选择的白色之后才有效，该定义高度依赖于

观察者的文化群体和白色物体的应用。在过去，存在并应用过数百个白度公式，但最常用的

只有 CIE白度指数和 Ganz白度指数。Ganz Whiteness（甘茨白度）公式不同于 CIE公式，CIE

白度公式是基于固定因子的，而 Ganz白度公式包含可变参数。 

W1/W2/W3/W4：
：：

：这几个数值必须通过使用一组校准样本的拟合程序来确定（DigiColor

已默认设置参数，不需要改变）。因此，它们不具有通用性，并且仅适用于特定的校准仪器。

当进行仪器间比较（特别是色度偏差值）时，该程序会产生令人满意的结果，但要付出不可

通用参数的代价。 

Phi：
：：

：色调偏好，指的是与 RWL（参考波长，为 470nm）垂直的角度，为 15。 

D：
：：

：Ganz白度公式对亮度 Y所求的偏导，固定为 1。 

Bandwidth：
：：

：此项为色调公式中的带宽，是与眼睛区分不同深浅白色的灵敏度有关的常

数，决定公式的缩放比例。 

9.5	Auto-grading	Opinion	自动评级自动评级自动评级自动评级选项选项选项选项	

通过 Setup→Options选择 AutoGrading标签栏（如图 9-6）。 

 

Template Location（模板定位）
（模板定位）（模板定位）

（模板定位） 

要确定模板位置的最大值和最小值，请执行以下操作： 

选择 Selection→Tools→Magic Wand魔术棒工具，在模板图像上左键选中其中一个白色

定位圆，圆的区域将显示在窗口底部的状态栏上。比如，S:(37*37)。默认的最小值应该比这

个值小 5(32)，最大值应该比这个值大 5(42)。 

Min（最小
（最小（最小

（最小值）

值）值）

值） 

 模板定位圆的最小半径以像素为单位。实际值取决于相机类型、图像大小和镜头类型，

应如上所述确定。 

Max（最大值）
（最大值）（最大值）

（最大值） 

 模板定位圆的最大半径以像素为单位。实际值取决于相机类型、图像大小和镜头类型，

应如上所述确定。 

Tolerance（
（（

（公

公公

公差）

差）差）

差） 

 建议为默认值 16。这是确定模板定位圆位置时的像素公差。 

注：如果公差值太高，则选择区域的位置可能会有差异，彼此间的多纤维选择框也许不

会相互平行。 
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模板管理器请参见第 9.5.1节 Template Manager模板管理器。 

Name（名称）
（名称）（名称）

（名称） 

 命名的模板将有一个对应的物理模板名，用于评级。 

Grading Value（评级值）
（评级值）（评级值）

（评级值） 

 切换输出的评级值。输出的评级将在灰度等级和数字之间切换。 

Auto Check（自动检查）。
（自动检查）。（自动检查）。

（自动检查）。 

 此功能当前未实现。 

Standard Multifibre（标准多纤维）
（标准多纤维）（标准多纤维）

（标准多纤维） 

 此选项用于存储模板的参照纤维的数据，此数据在每次摄像机校准后进行存储。此外，

应该每隔四小时重新测量一次。请在测量参照纤维数据之前检查此选项。这将存储数据以供

后续评估使用。存储数据后，该按钮将自动重置。 

Output results to a CSV file when saving the image?（当保存图像的时候输出一个
（当保存图像的时候输出一个（当保存图像的时候输出一个

（当保存图像的时候输出一个 CSV文件）
文件）文件）

文件） 

 如果勾选了此选项，则建议的默认文件名将是从系统注册表读取的 Auto-Grading对话框

中四个用户可定义的字符串。 

Multifabric Manager（
（（

（多织物管理器

多织物管理器多织物管理器

多织物管理器）

））

） 

 此项为多织物管理器，可进行新增多织物、修改现有的多织物及删除现有的多织物操作。 

Fastness formulae（色牢度公式）
（色牢度公式）（色牢度公式）

（色牢度公式） 

 您可选择标准 ISO色牢度评定公式（ISO 105-A04, A05）或者选择为新 ISO标准色牢度评

定公式（ISO 105-A11:2012）。 

 

图 9-6 Auto-grading选项设置界面 

9.5.1 AutoGrading Template Manager 自动评级模板管理自动评级模板管理自动评级模板管理自动评级模板管理 

 此选项可用于 AutoGrading（自动评级）模板的创建或修改，任何您创建或修改的模板
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必须符合已提供模板格式要求。当设计一个新的模板时，需符合基本的设计原则。您可以

联系客服代表获取设计新模板的建议。 

通过 Setup→Options→AutoGrading进入 Template Manager（如图 9-6中部）。 

NAME（名称）
（名称）（名称）

（名称） 

 此方框显示当前的 Auto-grading模板。您可以从下拉框中选择其它模板。 

Add New（添加新模
（添加新模（添加新模

（添加新模块

块块

块板

板板

板）

））

） 

您可以通过此按键在软件中定义新的模板。您应当从已经建好的模板中获得测量数据。

如果 DigiColor 已经提供模板了，您也将得到有着关键测量信息的数据表。如果您自己建立

模板，请设定关键的位置数据准确以确保测试样品位于正确的位置上。 

 
图 9-7 自定义模板 

样本坐标体系

样本坐标体系样本坐标体系

样本坐标体系（

（（

（X，
，，

，Y）
））

） 

 每个样本的位置根据样本在坐标体系中的坐标，以毫米为单位确定。坐标网格根据在每

个角落的共计四个定位小圆点确定，其中有 3个白点，1个黑点，黑点的位置在左上角，坐

标被设置为（0,0）。 

规定模板对象的坐标

规定模板对象的坐标规定模板对象的坐标

规定模板对象的坐标 

 规定的模板对象的坐标是相对于左上角黑点中心的坐标位置。模板对象指的是用于规定

样品测试区域的定位矩形而不是样品本身。模板最大宽度(X-gap)是 320mm, 最大高度(Y-gap)

是 200mm。 

多纤维织物方向

多纤维织物方向多纤维织物方向

多纤维织物方向 

 您只能竖直地放置您的样本条（即样本条的长边与 Y轴平行），而不能水平放置。 

Name of Template（
（（

（模板名称

模板名称模板名称

模板名称）

））

） 

 输入新模板的自定义名称。（详情可以在 Template Manager章节中查到） 

Number of Tests（
（（

（测试次数

测试次数测试次数

测试次数）

））

） 

 在模板中键入样品测试次数。测试的样本及其它相关的用作测量的织物条样本，作为 1

次计数。 

Reference Circles（
（（

（定位

定位定位

定位圆

圆圆

圆）

））

） 

 这定义了以毫米为单位的参考点的直径、点之间的宽度（X-Gap）和高度（Y-Gap）。这

些参数是确定的且只有在出现新模板时才进行更改。默认数据(Y-Gap)是 320mm，(X-

Gap)200mm，圆的直径为 8mm。 

Wool is close to the black Circle（
（（

（羊绒接近于黑色检测

羊绒接近于黑色检测羊绒接近于黑色检测

羊绒接近于黑色检测定位

定位定位

定位圆

圆圆

圆） 

 此复选框定义多纤维条的方向。如果羊毛多纤维最接近黑色圆圈，请选中此框。 

Specification of Test（
（（

（测

测测

测试规格

试规格试规格

试规格）

））

） 
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 用来区分测试物体的序号，序号从 1开始直到您在模板中所规定数目数。 

Name of Test（
（（

（测试名称

测试名称测试名称

测试名称）

））

） 

 测试名称出现在 AutoGrade结果对话框的相关列结果中。比如‘Acid Perspiration’. 

Untested Specimen X Y（
（（

（未测试样本的

未测试样本的未测试样本的

未测试样本的 X Y）
））

） 

这是未测试样本的位置矩形的左上角的坐标。它是距参照黑色圆中心的距离，单位为毫

米。 

注：该测量是指在未测试样品上绘制位置矩形的位置，而不是模板的模板角的位置。 

Untested Specimen Width Height（
（（

（未测

未测未测

未测试样本的宽度高度

试样本的宽度高度试样本的宽度高度

试样本的宽度高度）

））

） 

这是位置矩形的宽度和高度（以毫米为单位）。此矩形应至少距模板边缘 3毫米的地方

才能绘制，因为模板阴影可能会给出错误的评估。 

Test Specimen X Y（
（（

（测试样本的

测试样本的测试样本的

测试样本的 X Y）
））

） 

 这是被测织物样本相对于左上角黑点的矩形位置坐标，以毫米为单位。 

Test Specimen Width Height（
（（

（测试样本的

测试样本的测试样本的

测试样本的Width Height）
））

） 

 这是以毫米为单位的位置矩形的宽度和高度。这个矩形应该至少离模板边缘 3mm处开

始画，否则模板的阴影可能会干扰到矩形，使结果不准确。 

Multi-Fabric Specimen X Y（
（（

（多纤维样本

多纤维样本多纤维样本

多纤维样本 X Y）
））

） 

 这是被测多纤维织物样本相对于左上角黑点的矩形位置坐标，以毫米为单位。注意，多

纤维样本将自动产生 6个独立的矩形，每个矩形用于一种纤维样本的测试。 

Multi-Fabric Specimen Width Height（
（（

（多纤维样本

多纤维样本多纤维样本

多纤维样本的

的的

的Width Height）
））

） 

 这是以毫米为单位的位置矩形的宽度和高度。这个矩形应该至少离模板边缘 3mm处开

始画，否则模板的阴影可能会干扰到矩形，使结果不准确。矩形的宽度应该尽可能小，避免

多纤维条的边缘磨损对测试结果有影响。 

注：设置任何样本的宽度或高度为“0”将从模板中移除此样本。这个选项可以让你选

择想要测试的项目，比如只要测沾色牢度或者只要测变色牢度。 

Copy From Test 1（
（（

（从

从从

从测试

测试测试

测试 1中拷贝数据）
中拷贝数据）中拷贝数据）

中拷贝数据） 

 如果勾选此框，则会将测试 1的坐标数据复制到文本框中。这提供了通过复制和编辑原

始数据向模板添加多个测试的快速方法。 

Modify按键
按键按键

按键 

 这个按键可以用来修改 Template Manager列表中一个已存在的模板数据。 

Delete按键
按键按键

按键 

 这个按键可以用来删除 Template Manager列表中一个已存在的模板数据。 

9.6	Auto-pilling	Opinion	起球自动评级选项起球自动评级选项起球自动评级选项起球自动评级选项	

 通过 Setup→Options→Auto-pilling打开 Auto-pilling（如图 9-8）。 
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图 9-8 Auto-pilling选项标签 

Template Location（
（（

（模板

模板模板

模板定位

定位定位

定位）

））

） 

Min（
（（

（最小值

最小值最小值

最小值）

））

） 

 模板定位圆的最小半径（以像素为单位）。实际值取决于相机类型、图像大小和镜头。 

Max（
（（

（最大值

最大值最大值

最大值）

））

） 

 模板定位圆的最大半径（以像素为单位）。实际值取决于摄像机类型、图像大小和镜头

类型，应如上所述确定。 

Tolerance（
（（

（公差

公差公差

公差）

））

） 

 这是确定模板定位圆位置时的像素公差，建议默认值为 16。 

Display Binary Image（
（（

（显示二值图像

显示二值图像显示二值图像

显示二值图像）

））

） 

 将捕获的图像显示为由黑白两种颜色构成的图像。 

操作步骤

操作步骤操作步骤

操作步骤：

：：

： 

a. 将测试样品和原始样品并排放置在起球样品架中； 

b. 对起球的样本进行拍照； 

c. 在 DigiColor菜单里或者工具栏中选择 Auto-pilling； 

d. 根据您的需要打印或保存数据。 
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10. Toolbar 工具栏工具栏工具栏工具栏 

工具栏按钮允许您快速方便地访问常用程序。这些按钮与菜单栏中的内容相关联，并根

据其功能划分为多个组。以下是每个按钮功能的简要说明。 

Windows标准的打开和编辑按钮：
标准的打开和编辑按钮：标准的打开和编辑按钮：

标准的打开和编辑按钮： 

1.  文件打开和保存 

2.   剪切，粘贴，复制 

3.   撤销和恢复 

4.   打印 

相机和相机校准按钮：

相机和相机校准按钮：相机和相机校准按钮：

相机和相机校准按钮： 

1.  捕获图像 

2.  开始监视器校准，也可通过 Calibration→Monitor Calibration打开 

3.  打开仪器校准，也可通过 Calibration→Instrument Calibration打开 

数据管理按钮：

数据管理按钮：数据管理按钮：

数据管理按钮： 

1.  打开数据管理窗口，也可通过 Color Management→Data Manager打开 

2.  打开光谱测量窗口，也可通过 Color Management→Spectro Measuring打开 

3.  打开质量管理窗口，也可通过 Color Management→Quality Control打开 

4.  打开颜色特征窗口，也可通过 Color Management→Color Specification打开 

DigiColor颜色
颜色颜色

颜色成像

成像成像

成像操作按钮：

操作按钮：操作按钮：

操作按钮： 

1.  打开颜色替换窗口，也可通过 Color Imaging→ImagePixel→Color Replacing打开 

2.  打开纹理映射窗口，也可通过 Color Imaging→Texture Mapping打开 

3.  打开纹理矩阵窗口，也可通过 Color Imaging→Texture Matrix打开 

4.  打开颜色聚类窗口，也可通过 Color Imaging→ImagePixel→Color Clustering打开 

DigiColor评级操作按钮：
评级操作按钮：评级操作按钮：

评级操作按钮： 

1.  开始自动评级，也可通过 Color Imaging→Auto Grading打开 



83 

 

2.  开始起球评估，也可通过 Color Imaging→Textile Pilling打开 

图像导

图像导图像导

图像导航

航航

航： 

1.  区域放大和缩小 

2.  动态缩放工具 

3.   抓手工具，在屏幕中移动图像 

4.  1:1的图像尺寸，调整图像至实际的尺寸 

区域选择

区域选择区域选择

区域选择工具

工具工具

工具：

：：

： 

1.   魔术棒工具，选择一系列相似的颜色，也可通过 Selection→Tools→Magic 

Wand打开 

2.   矩形选择工具，选择一个矩形形状的区域，也可通过 Selection→Tools→

Rectangle打开 

3.   圆形选择工具，选择一个圆形形状的区域，也可通过 Selection→Tools→

Circle打开 

4.   固定尺寸的矩形选择工具，也可通过 Selection→Tools→Fixed-Rectangle打

开 

5.   固定尺寸的圆形选择工具，也可通过 Selection→Tools→Fixed-Circle打开 

6.   移动选择工具，对选择区域进行移动重选，也可通过 Selection→Tools→

Move打开 
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11. DigiColor 的维护的维护的维护的维护 

标准

标准标准

标准色卡

色卡色卡

色卡和

和和

和标准

标准标准

标准白

白白

白板：

板：板：

板： 

不使用时，标准色卡和标准白板应放入保护套中，放置于干燥避光处。使用时应避免手

指直接接触色卡颜色表面和白板正面，应避免硬物划伤色卡和白板表面，应避免灰尘、水渍、

染料、油漆、油墨等污染色卡和白板表面。建议每年或视使用情况及时更换标准色卡和标准

白板，避免影响测量精度。 

 

LED照明
照明照明

照明灯

灯灯

灯：

：：

： 

在正常使用情况下，LED灯珠有足够长的使用寿命。如果出现仪器标定异常情况，应及

时检查 LED灯珠发光是否正常或联系客服。 

 

仪器

仪器仪器

仪器柜

柜柜

柜：

：：

： 

柜内表面应每年清洁一次，如果有标记或脏污，则应更频繁地清洁。 

注 1：白色的灯光反光器不得涂漆。分层的内饰不应涂漆，而应使用湿布擦拭干净。如

果内部特别脏，则必须使用温和的清洁剂，通过除尘或用柔软的干净的湿布擦拭来保持灯反

射器的清洁。 

注 2：不应使用溶剂和研磨性清洗液。 

 


